OH 3.2: Wolf Smartset Binding - Null Pointer Exception

Dear community,
dear @BoBiene,

I would like to use the Wolf Smartset Binding that is now officially available as a binding in OH 3.2.
Setting up the the “Account” Thing works fine. Based on this I can set up the “System” thing as well and meta data like the FW is shown. Discovery of “Unit” things works, too.

Unfortunately updating the things and polling further data is not working :frowning:

The binding throws a NullPointerException:

2021-12-23 12:41:15.497 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception: 
java.lang.NullPointerException: null
	at org.openhab.binding.wolfsmartset.internal.handler.WolfSmartsetUnitThingHandler.updateValues(WolfSmartsetUnitThingHandler.java:188) ~[?:?]
	at org.openhab.binding.wolfsmartset.internal.handler.WolfSmartsetAccountBridgeHandler.refreshSystems(WolfSmartsetAccountBridgeHandler.java:252) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) ~[?:?]
	at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:305) ~[?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:305) ~[?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
	at java.lang.Thread.run(Thread.java:829) [?:?]

I am running on a Raspi 4 with openHABian OH 3.2 and I am connecting to a Wolf Smartset Pro.
Is anybody else encountering this problem? What else can I do to debug or solve the issue?

Thx for your support best regards

I think i found the specific error you have. But i’m not able to test it with the Smartset Pro.

Can you please check if it is working with this bundle?
Filebin | li7n9043sff4nv67

Thx for your immediate action.

I removed the binding and installed the provided one via the addons folder.

Unfortunately it is not yet working.

The error message is still the same :frowning:

I am not sure if its relevant but I saw that at one point it started updating the items connected to my thing. But after 5 items the error was thrown again…

@Turbo-B thank you for sharing access to your heating system. I cloud reproduce the issue, and with this version it worked for me: Filebin | pb6qouizgtmuci0i
Can you please verify if it is working for you?

Hi @BoBiene,
It works and updates my items. THX for solving the issues :slight_smile:

Hi, i’ve the same problem, but can’t download the solution, @BoBiene Can you please access the solution again :grinning:

The Pullrequest with the fix is merged: [wolfsmartset] Fix NullPointerException when updating values by BoBiene · Pull Request #11931 · openhab/openhab-addons · GitHub and it should work with the current snapshot build of the binding.
Did you try this version?

Hi sorry for my late answer, the snapshot build of the binding is no longer aviable on filebin or?


please checkout Release openHAB 3.3.0 Milestone 1 · openhab/openhab-distro (github.com) the fix is part of this release.



I’ve installed the milestone version and it works, but now i’m getting this

error message:

[C:04.175 [WARN ] [smartset.internal.api.WolfSmartsetApi] - getGetParameterValuesString failed with org.openhab.binding.wolfsmartset.internal.api.WolfSmartsetCloudException: Error too many requests: {“Message”:“Der Portal-Server reagiert nicht. Bitte versuchen Sie es sp\u00E4ter nochmal.”,“ErrorCode”:10,“ErrorType”:1,“Errors”:null,“MessageParams”:null}: org.openhab.binding.wolfsmartset.internal.api.WolfSmartsetCloudException: Error too many requests: {“Message”:“Der Portal-Server reagiert nicht. Bitte versuchen Sie es sp\u00E4ter nochmal.”,“ErrorCode”:10,“ErrorType”:1,“Errors”:null,"Messa " } ]

It seems like i’m getting for an hour the data, and then this error comes for an hour: