OH 3.3.0 Frontail not Starting after fresh installation

I have exactly the same.

Hello,
After downloading newest version 1.7 i have exactly the same problem as coleague above.
Could anybody help?

[...[
+ npm audit fix --force
npm WARN using --force Recommended protections disabled.
npm WARN old lockfile
npm WARN old lockfile The package-lock.json file was created with an old version of npm,
npm WARN old lockfile so supplemental metadata must be fetched from the registry.
npm WARN old lockfile
npm WARN old lockfile This is a one-time fix-up, please be patient...
npm WARN old lockfile
npm WARN audit Updating jsdom to 20.0.3, which is a SemVer major change.
npm WARN audit Updating mocha to 10.1.0, which is a SemVer major change.
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated debug@3.2.6: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797)
npm WARN deprecated debug@4.1.1: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797)
npm WARN deprecated formidable@1.2.1: Please upgrade to latest, formidable@v2 or formidable@v3! Check these notes: https://bit.ly/2ZEqIau
npm WARN deprecated uuid@3.3.2: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
npm WARN deprecated request@2.88.0: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated superagent@3.8.3: Please upgrade to v7.0.2+ of superagent.  We have fixed numerous issues with streams, form-data, attach(), filesystem errors not bubbling up (ENOENT on attach()), and all tests are now passing.  See the releases tab for more information at <https://github.com/visionmedia/superagent/releases>.
npm WARN deprecated buster-core@0.6.4: No longer maintained

added 505 packages, and audited 506 packages in 4m

43 packages are looking for funding
  run `npm fund` for details

# npm audit report

engine.io  4.0.0 - 6.2.0
Severity: high
Uncaught exception in engine.io  - https://github.com/advisories/GHSA-r7qp-cfhv-p84w
fix available via `npm audit fix --force`
Will install socket.io@4.5.4, which is a breaking change
node_modules/engine.io
  socket.io  3.0.0-rc1 - 4.4.1
  Depends on vulnerable versions of engine.io
  node_modules/socket.io

2 high severity vulnerabilities

To address all issues (including breaking changes), run:
  npm audit fix --force
+ return 1
+ echo 'FAILED (install)'
FAILED (install)

Same here.

Is there any current problem with frontail ?
I tried now three times a “fresh” installation of openhabian (v.1.7.4b and also v1.7.4 from GitHub - openhab/openhabian: openHABian - empowering the smart home, for Raspberry Pi and Debian systems) on a Pi4.

It’s always the same result:

  • http://openhabian:9001 → doesn’t show any frontail.
  • sudo systemctl status frontail → “Unit frontail.service could not be found.”
  • Re-install frontail with sudo openhabian-config and then option 21 “Log Viewer” failes with: "There was an error or interruption during the execution of: | “20 | Optional Components” "

Found a lot of different solutions from the past years (mainly old ones from 2020, 2021), but none of them could help so far…

BR

Which version of the package nodejs is installed in the cases where frontail is not running ?
You may use the command dpkg -l nodejs to identify the installed version.
Command nodejs --version should return the same version information.

In my very case it is:

||/ Name Version Architektur Beschreibung
++±==============-========================-============-=================================================
ii nodejs 16.18.1-deb-1nodesource1 armhf Node.js event-based server-side javascript engine

Same for me:

||/ Name Version Architecture Description
++±==============-========================-============-=================================================
ii nodejs 16.18.1-deb-1nodesource1 armhf Node.js event-based server-side javascript engine

I just upgraded nodejs in an existing VM that contains debian 11 / bullseye from 16.17.0 to 16.18.1.
The nodejs package itself is not the problem - frontail still works.

Try the following:

  • login to your OH system via putty/ssh/telnet/any other way that you offers a shell
  • sudo bash
  • pay attention you have a root shell now; take care what you do; in case of errors read them; in case of an error stop instead of just continuing
  • cd /opt/frontail
  • npm audit fix --force
  • systemctl start frontail
  • systemctl status frontail should show that frontail is online alternatively you may connect using the bowser

Root cause of the problem was/is that there is a breaking change in an npm module. openhabian-config does not continue to install that breaking change. This is done manually with the above commands.

Hi @Wolfgang_S,

thanks for you help! But seems like not succesful:

This is what i did now:
sudo bash
root@openHABV2:/home/openhabian# cd /opt/frontail
root@openHABV2:/opt/frontail# npm audit fix --force
This is the output:

npm WARN using --force Recommended protections disabled.
npm WARN audit Updating socket.io to 4.5.4, which is a SemVer major change.

added 1 package, removed 8 packages, changed 19 packages, and audited 499 packages in 12s

43 packages are looking for funding
run npm fund for details

found 0 vulnerabilities

Then:
root@openHABV2:/opt/frontail# systemctl start frontail
Output:

Failed to start frontail.service: Unit frontail.service not found.

root@openHABV2:/opt/frontail# systemctl status frontail
Output:

Unit frontail.service could not be found.

Hi @Wolfgang_S ,
The problem is that we are not able to install frontail after new installation.
As frontail is not installed by default on fresh install, we need to install it manually.
Each time when i’m trying to install it by using openhabian-config i have message:
"Log Viewer” failes with: "There was an error or interruption during the execution of: | “20 | Optional Components”
Full error log:

[...[
+ npm audit fix --force
npm WARN using --force Recommended protections disabled.
npm WARN old lockfile
npm WARN old lockfile The package-lock.json file was created with an old version of npm,
npm WARN old lockfile so supplemental metadata must be fetched from the registry.
npm WARN old lockfile
npm WARN old lockfile This is a one-time fix-up, please be patient...
npm WARN old lockfile
npm WARN audit Updating jsdom to 20.0.3, which is a SemVer major change.
npm WARN audit Updating mocha to 10.1.0, which is a SemVer major change.
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated debug@3.2.6: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797)
npm WARN deprecated debug@4.1.1: Debug versions >=3.2.0 <3.2.7 || >=4 <4.3.1 have a low-severity ReDos regression when used in a Node.js environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https://github.com/visionmedia/debug/issues/797)
npm WARN deprecated formidable@1.2.1: Please upgrade to latest, formidable@v2 or formidable@v3! Check these notes: https://bit.ly/2ZEqIau
npm WARN deprecated uuid@3.3.2: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
npm WARN deprecated request@2.88.0: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated superagent@3.8.3: Please upgrade to v7.0.2+ of superagent.  We have fixed numerous issues with streams, form-data, attach(), filesystem errors not bubbling up (ENOENT on attach()), and all tests are now passing.  See the releases tab for more information at <https://github.com/visionmedia/superagent/releases>.
npm WARN deprecated buster-core@0.6.4: No longer maintained

added 505 packages, and audited 506 packages in 4m

43 packages are looking for funding
  run `npm fund` for details

# npm audit report

engine.io  4.0.0 - 6.2.0
Severity: high
Uncaught exception in engine.io  - https://github.com/advisories/GHSA-r7qp-cfhv-p84w
fix available via `npm audit fix --force`
Will install socket.io@4.5.4, which is a breaking change
node_modules/engine.io
  socket.io  3.0.0-rc1 - 4.4.1
  Depends on vulnerable versions of engine.io
  node_modules/socket.io

2 high severity vulnerabilities

To address all issues (including breaking changes), run:
  npm audit fix --force
+ return 1
+ echo 'FAILED (install)'
FAILED (install)

I’ve tried with many version of node js (12.x,14.x,16.x and even 18.x). Still the same problem and exactly the same errors.

1 Like

I have the same error while using openhabian-config → install logviewer on my debian machine.

But I am able to run frontail correctly with the command from here openhabian/frontail.service at main · openhab/openhabian · GitHub inside the /opt/frontail folder:
frontail --disable-usage-stats --ui-highlight --ui-highlight-preset preset/openhab_AEM.json --theme openhab_AEM --lines 2000 --number 200 /var/log/openhab/openhab.log /var/log/openhab/events.log

So just the npm install failes.

Thank you, that helped!

1 Like

Hi @Desmond206x,
Seems that it works!
But how to autostart this process during system startup?

That I understood from earlier posts.

So I removed the frontail installation and did a fresh install after I upgraded all apt packages and then used openhabian-config to do a new installation of frontail which then also resulted in the message

after that I followed the hint that is given by the “to address all issues” message as I described in my previous post. The nodejs version that is installed here is 16.18.1 as described by others as well.

Because the installation was aborted the service file was not installed.

Code lines of the script that are not executed are:

  if ! (sed -e "s|%FRONTAILBASE|${frontailBase}|g" "${BASEDIR:-/opt/openhabian}"/includes/frontail.service > /etc/systemd/system/frontail.service); then echo "FAILED (service file creation)"; return 1; fi
  if ! cond_redirect chmod 644 /etc/systemd/system/frontail.service; then echo "FAILED (permissions)"; return 1; fi
  if ! cond_redirect systemctl -q daemon-reload; then echo "FAILED (daemon-reload)"; return 1; fi
  if ! cond_redirect systemctl enable --now frontail.service; then echo "FAILED (enable service)"; return 1; fi
  if cond_redirect systemctl restart frontail.service; then echo "OK"; else echo "FAILED (restart service)"; return 1; fi # Restart the service to make the change visible

  if openhab_is_installed; then
    dashboard_add_tile "frontail"
  fi

These lines that the service template file; do modifications using sed command and saving the file in /etc/systemd/system/frontail.service. With following lines permissions are adapted and the service is enabled. If you do these steps manually you can enable a start of the service at boot time.
Subroutine dasboard adds a link to Main UI app section.

that I missed because in my case the service file was still there from previous install.
As described in the other post a few steps from the installation script need to be done to create the service file and enable the service.