OH 3 Rules do not trigger

Dear Community, I used OH 2.x in the past with some stable running rules in DSL and doing my first steps now on OH 3, where I want to change to ECMA for the rules. But the current huge issues are the triggers, that don’t work.
I could find a solution in the community yet.

openHAB 3.2.0. Release Build; APT installation on Debian 10/buster

For days I am fiddling around to get rules triggered by change of a state.
Tried rules in DSL, ECMA and Blockly - each trigger configured in the UI - none worked.

Here is a simple test rule where the trigger does not work. No entries in the logs caused by the triggered rule.

configuration: {}
  - id: "1"
      itemName: ch_BsmtSr_Plug_WaMa
    type: core.ItemStateChangeTrigger
conditions: []
  - inputs: {}
    id: "2"
      type: application/javascript
      script: >-
        var logger =
        Java.type('org.slf4j.LoggerFactory').getLogger('org.openhab.rule.' +

        logger.info('MB Rule Trigger Test ECMA START. Current power consumption: ' + itemRegistry.getItem('ch_BsmtSr_Plug_WaMa').getState() + " W");
    type: script.ScriptAction

Only when I press the “Run Now” button I get the expected log entry. So the rule itself seems to work and the value of the plug (34 W) is there.

==> /var/log/openhab/openhab.log <==

2022-01-15 23:26:19.669 [INFO ] [org.openhab.rule.Trigger_Test_ECMA  ] - MB Rule Trigger Test ECMA START. Current power consumption: 34 W

With another test rule I tried “Trigger at a specific time” - that didn’t work either.
The only rule that is running is triggered by “When the system has reached start level: 50”.

Thanks a lot - any hint is appreciated!

Your rule configuration looks correct. Are you sure that the item is actually changing state? Do you see entries in the events.log file for your ch_BsmtSr_Plug_WaMa item that look like this:

2022-01-15 16:27:21.527 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'Sensor_MasterBedroom_LightLevel' changed from 9 to 6

If you don’t see a log line that says changed in it then a rule with an item changed trigger won’t run.

Thanks JustingG for your reply and the confirmation that the rule config is correct.
Sorry - I forgot to mention that the value is changing permanently - fluctuates around 34 Watts approx. every minute. Here is an example from the logs:

==> /var/log/openhab/events.log <==
2022-01-15 23:50:40.422 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'ch_BsmtSr_Plug_WaMa' changed from 35 to 33

2022-01-15 23:50:50.468 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'ch_BsmtSr_Plug_WaMa' changed from 33 to 34

2022-01-15 23:51:30.496 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'ch_BsmtSr_Plug_WaMa' changed from 34 to 35

2022-01-15 23:51:40.437 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'ch_BsmtSr_Plug_WaMa' changed from 35 to 34

2022-01-15 23:52:30.519 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'ch_BsmtSr_Plug_WaMa' changed from 34 to 35

That’s why I am running out of ideas. Maybe somehing is corrupted with my OH 3 installation. Hope I have the time to get a Docker container running for testing purposes the next days.