OH 4.0.1 - "Could not determine addons folder" on binding installation

I have upgraded OH on my Synology NAS (Docker) from 3.4.4 to 4.0.1. Now all bindings are shown as not installed and clicking on install button loads forever. It’s interesting to note that this only effects official bindings. The logs show the following error:

2023-08-14 19:43:53.321 [WARN ] [core.karaf.internal.FeatureInstaller] - Could not determine addons folder, its content or the list of installed repositories!
2023-08-14 19:43:53.322 [INFO ] [core.karaf.internal.FeatureInstaller] - Some .kar files are not installed yet. Delaying add-on installation by 15s.

The web interface is still accessible.
I tried cleaning the cache and found some threads with the same errors after updating OH. But the configuration file for the service org.apache.felix.fileinstall looks as expected. Running config:list "(service.pid=org.apache.felix.fileinstall*)" shows only one instance and the referenced directories all exist and are read/writable by the openhab(-docker) user with uid 9001:

Pid:            org.apache.felix.fileinstall~deploy                              
FactoryPid:     org.apache.felix.fileinstall                                     
BundleLocation: ?                                                                
   felix.fileinstall.active.level = 90                                           
   felix.fileinstall.dir = /openhab/addons                                       
   felix.fileinstall.filename = file:/openhab/userdata/etc/org.apache.felix.filei
   felix.fileinstall.filter = .*\.(jar|kar)                                      
   felix.fileinstall.log.level = 3                                               
   felix.fileinstall.poll = 10000                                                
   felix.fileinstall.start.level = 80                                            
   felix.fileinstall.subdir.mode = skip                                          
   felix.fileinstall.tmpdir = /openhab/userdata/tmp/bundles                      
   service.factoryPid = org.apache.felix.fileinstall                             
   service.pid = org.apache.felix.fileinstall~deploy

I “solved” it by downgrading back to version 3.4.4.