OH 4.0.3: Semantic model gets corrupted / blocked again and again

  • Platform information:
    • Hardware: Raspberry Pi 4 / 8GB
    • OS: latest openhabian (OH 4.0.3)

I have a quite huge setup with almost 500 items at this time, and still growing. Currently I have finished the semantic model (using the GUI) about 90% and I am starting to test the first rules. So far, so good.

Within the last days, I ran into very strange behaviors of the semantic model, as it suddenly no longer accepts any changes and just stays the same.
This means that:

  • Adding a location, point, etc. first looks normal, it appears on the tree when giving it a name, but then disappears again when saving. Interestingly, the item as such is created, its parent and / or member group entries are correct. But it never appears on the model page, neither does it in any system dialog based on the model (e.g. pickers in the rules section). Restarting the OH service, rebooting, just waiting, fix permissions on openhabian-setup, restoring jsondb-backup all did not help.
  • The same happens when deleting entries from the model. All items, parent and member groups are updated correctly, but nothing happens in the model. It does not matter where this is done (model page or items page). It even tries to access no longer existing items, which then have a state of “-” (not even NULL or NONE). When trying to delete these from the model again, it refuses and issues that the item is no longer existing.
  • Nothing is ever displayed in the logfile (except when trying to acces a non-existent item).
  • All entries in the jsondb files look healthy, and copying a known-working backup there does not help.
  • Until yesterday, it sometimes worked if I restored a full backup (via openhabian-setup). By now, even this fails. I restore a backup from some days ago where I am sure it was working and the issue remains.
  • I tried clearing the jsondb and the persistence even manually before restoring (persistance afrer restoring as well).

Sometimes it unblocked the model for one or two days, but then it went back into this state.

All the rest of OH is still working as intended. So it’s somewhat usable, but with a frozen-state semantic model, and I am running out of ideas… grateful for help!

Are you using Firefox? There is a known issue with Firefox where it too aggressively caches stuff from OH meaning that changes that you make, particularly from the Model view, do not appear until a hard reload of the page.

Please try in another browser and/or do a hard reload of the page.

It wouldn’t because it’s strictly a browser issue, not a server issue.

1 Like

OMG yes… Thanks for the very quick reply.

Yeah, well, what shall I say… I tried it with Chrome and it worked. :sweat_smile: :+1:

It all makes sense, of course, I just would not have guessed it’s the browser. Thanks a lot!

1 Like