OH v2.5 and MQTTv1.x

Hi all,
I was surprised when my stable OH system crashed last night and found it was partly my fault as I had not excluded openhab2 from the apt updates it runs at noght this has been stable since I regained control after last Christmas upgrades.

I have now corrected my apt hold blunder so no more surprises.
I have read the breaing section of the 2.5 release notes and corrected the REST UI change, and noted that NMQTT 1.x was not depreciated so carried on looking why my MQTT devices (sonoffs) are not being controlled.

I have ran MQTT client and can see that my devices are chatting away bit I see nothing from OH.
I have checked it is still showing as installed in paper UI and the system flag to use legacy bindings is set too.

I have rebooted multiple times and still no MQTT activity. A check on search shoes no recent posts since v2.5 was dropped about this subject, I appreciate that I am in the minority still running MQTT 1.x but have not yety had the time to migrate the system to MQTT 2.x

looking at the CLI I see:

226 │ Active │  80 │ 1.14.0                  │ openHAB Mqtt Action
235 │ Active │  80 │ 1.14.0                  │ openHAB MQTT Binding
247 │ Active │  80 │ 1.14.0                  │ openHAB MQTT Transport Bundle

I must admit I thought it used to be MQTT 1.13 so has it also been upgraded?
What should I try next?

Do you really need the MQTT Action?
https://www.openhab.org/addons/actions/mqtt/
I remember some old threads where the actions caused issues.
If you don’t need them, uninstall, clear the cache, reboot.

2 Likes

The v1 bindings routinely get a version bump alongside the parent 2.x version hosting them. This does not imply there have been any actual changes to the binding.

I would look in openhab.log to see what the binding has to say for itself at startup. “Nothing” would also be a clue. Checkout mqtt.cfg and its content is as you expect.

Also clear the cache if you have not.

Indeed. For a long time it was impossible to use the Action. Then for awhile it became an issue only sometimes or based on the order that they got installed. Among the things you try, definitely try uninstalling the MQTT Action. If you still need it, reinstall it and cross your fingers. If reinstalling it beaks things again, you may need to use an alternative using Items instead of the Action.

I’ve seen the same on a few of my mqtt2 things. All of those were due to not totally correct transformations. It seems to me, that the handling of transformation errors is now silent while it was exception spitting before. This may be the same for mqtt1 transformations, but i may be totally wrong.

Hi all,
I could have sworn I wrote a detailed response on this thread that explained all the things I had done nd also indicated that uninstall MQTT actions may be causing an MQTTbroker error.

Cut a long story short removing the MQTT actions caused and error and a restart did not fix it. Added the MQTT action back in and the error stopped another restart fixed it.
The clear-cache etc did not seem to make a difference but could of course been more than one activity that resulted in it starting to work.

Thanks Everyone, I can still see I have some errors in my log but I will look at them later.

Regards

Paul

1 Like

I have exactly the same problem… I will try uninstalling the MQTT action now and hope it’ll fix it.

I had zigbee2mqtt with mosquitto and the legacy mqtt binding working just fine before the update…

Edit: Uninstalled MQTT Action, restarted zigbee2mqtt service. All is fine!

1 Like

Thanks, after scratching my head why no events were processed through the MQTT legacy binding (1.14) i also uninstalled the MQTT Action legacy binding. Now working as before the upgrade.