OH1 bindings and immediate="true" for OH2

Just been testing my Siemens Logo! PLC binding [yes, I know, still unreleased :frowning: ]with OH2 and also found that I needed to change the binding.xml with immediate=“true” in order that the refresh service got started without being immediately stopped. I’d guess by now most OH1 binding authors with similar background polling services will have found the same but I thought I’d flag it.

1 Like

Yes that is a problem that was discovered just after OH 2 beta 1 was released.
Most (maybe all ?) of the bindings 1.x have been updated to add immediate=“true”.

I converted about 120 or more of them! :smile:


I used the 1.8.3 versions of the novelanheatpump and the networkupstools binding, and they still seem to have this issue that the update stops.

I would only suggest bothering to try openHAB 1.x addons from here — not 1.8.* versions — and then, only if they are not already packaged with openHAB 2.

And for those that work (and are not already installable from openHAB 2), please let us know so we can add them to openHAB 2. Thanks!

I swapped them out for the versions you provided, but no change. The items don’t update. Probably there are other compatibitlity issues as well.

Under openHAB 2, there might be different steps to replace the addon. Are you sure the old JARs were fully uninstalled before adding the new ones to the addons folder? At the openhab> prompt, did you use commands like bundle:list and bundle:uninstall? Just making sure you are seeing the 1.9 snapshot JARs fail in action…

oh dear, so much to learn :slight_smile:

I uninstalled the 1.8.3 bindings. At least the novelanheatpump is working now. networkupstools is still not updating its items, it fails silently, there is nothing whatsoever in the log, even if I run it with start_debug.

networkupstools works now as well. It seems the config still needs the prefix “networkupstools:” in front of every configuration directive.

1 Like

If the keys were in a file called networkupstools.cfg, is this still true? It should only be true if the config values were still in openhab.cfg.

If we can confirm that novalanheatpump and networkupstools bindings are working properly in OH2, I will submit a PR to allow them to be installed directly, and also update the list.


yes, the configuration was in services/networkupstools.cfg

even so, it was only after i added the prefix that the binding actually started working.

Wow, that’s a weird one! I will submit a pull request regardless, and perhaps you could test again on the next OH2 distro that contains the change? Thanks, John