OH1: not wanting OH to log to syslog?!

How can I prevent OH1 to log to syslog, given it logs all its logs in /var/log/openhab/ already?

Which facility is OH logging to? You might be able to fix this in the syslog configuration.

via rsyslog.d to /var/log/syslog

Aug 19 12:56:39 rpiautomation openhab.sh[9449]: 2017-08-19 12:56:39.314 [INFO ] [runtime.busevents             ] - Shed_Humi_Min state updated to 33.2
Aug 19 12:56:39 rpiautomation openhab.sh[9449]: 2017-08-19 12:56:39.325 [INFO ] [runtime.busevents             ] - Shed_Humi_Max state updated to 43.5
Aug 19 12:56:41 rpiautomation openhab.sh[9449]: 2017-08-19 12:56:41.444 [INFO ] [runtime.busevents             ] - Shed_Lux_KDL state updated to 326.13

Yeah, that wasn’t the question.

But I see it’s not quite syslog. Here’s some good reading on rsyslog selectors.

1 Like

is there a *.conf file within /etc/rsyslog.d/ with the logging configuration for openhab ?
if not, is there anything specific to OH1 in /etc/rsyslog.conf ?
If not… somewhere in the OH1 files, there is a setting for the syslog facility that is being used (e.g. local0 or local5, etc)
If you can identify the log facility (like @namraccr mentioned), you can use the selectors.

edit: he was fast :slight_smile:

1 Like

Thanks… I figured it out…

It is not telling OH1 to stop logging – it is about telling syslog to discard the messages…

editing /etc/rsyslog.conf
and adding this add the top:

# 170819-2135 MaxG: added to suppress openHAB entries
:msg, contains, "runtime.busevents" stop

will result in no busevents being logged -> as they are already logged i in openhab.log and events.log