OH2 and Eclipse Smart Home designer - folder structure unsupported?

Maybe I’m doing something wrong - or the (new) designer isn’t as far in its development as I expect.
I’m using the “new” Designer on Windows, accessing my config files on my Raspberry via Samba.

Under OH1 this worked very well - when I’ve chosen the directory in the “old” designer, the folder structure appeared - and I was able to edit all necessary files within one interface.

Now, it seems the new designer doesn’t support the subfolders; if I e.g. choose “sitemaps” as config folder, I can edit the sitemap. But if I want to edit the items also, I have to choose the items folder as config folder. And so on.
In the old version, I just chose the root of the config - and was able to switch directories within the designer.

Am I doing something wrong - or is this a “feature”?

Thank you!

I’m not sure what is wrong with your config. I just chose the conf folder similar to how I would choose the configurations folder in OH 1.x and it worked as expected.

1 Like

Hmmm…where exactly is this “conf” folder?
All my configs are under /etc/openhab2. There are the folders html, icons, items, persistence,…etc - but no “conf”.
When I choose the folder /etc/openhab2, I get the behaviour I described.

What should the folder structure look like?


Ouch, that’s nasty!
Found the problem: Seems like the Smart Home Designer doesn’t support UNC shares, like \\servername\sharename

As soon as I connect a network drive (e.g. the letter o: connecting to \\servername\sharename), the folder structure shows up, when I’m using the assigned drive (letter O:).

Either a “feature” in the Designer - or come configuration problem with my samba installation.

My mistake. I assumed that the apt-get install of OH 2 structured /etc/openhab2 similarly to the way it did for openHAB 1.x, which has a configurations folder. I’m running in Docker so have a manual install which does have a root conf folder. Apparently they did away with that in OH 2.

That is actually a pretty common problem. I’ve found more programs I’ve tried to use on Windows do not support UNC shares than do.

1 Like

Just found this post after i banged my head for a while trying to figure what the issue was … This “Feature” SUCKS! Especially since all the documentation points users to use the ESHD and its not working out of the box. Best thing to share entire /etc folder in 777 mode… :\

And don’t get me started on the configuration options of the ESHD itself … useless … network discovery takes ages, when there could simply be a way to manually add network share. How about working with multiple shares on different machines?

If you must, then just share the /etc/openhab2 folder. No need to expose your entire etc.

I don’t understand what you are saying. If you are talking about trying to browse to a network share in ESHD, then you can either type in the path (//IP/openhab2) or map it as a network drive.

Remember, despite some advanced options, ESHD is essentially just a text editor. To expect more from it is to be disappointed.

Unfortunately ESHD can only load one config at a time.

Having just struck this problem myself (never mind the getting samba to work on linux) Would it be worth adding to: http://docs.openhab.org/installation/designer.html That UNC paths aren’t supported from windows.

It would be helpful if you filed an Issue on the openhab-docs github and I’m sure it will be updated.