OH2 and homematic HM-PB-6-WM55 does not work

Hello Guys.

Today i tried to integrate the homematic HM-PB-6-WM55 (a wall mounted wireless device with 6 buttons).

PaperUI found it and linked 12 channels (6 for long pressing a button, and 6 for short pressing).
Everything is OK. No errors (not in homematic-ui, not in oh2).

when i klick on the oh2-switch (linked to channel 6-short-press) the “…received update to ON”-rule for this item triggers as expected.
but when i press the device-button 6 (short or long), nothing happens within OH2.

after that i switched off AES within paperUI for all 6 channels.
Same error.

Now i made a direct connection between the device-button-6 and a homematic-230V-socket just for testing.

when i klick on the oh2-switch (linked to channel 6-short-press) the “…received update to ON”-rule for this item triggers AND the socket toggels.
but when i press on the device button 6 (short or long), just the socket toggels but nothing happens within OH2.

so it seems it just works 1way…commands from oh2 to 6-button-device (at least to ccu2) work.
from the device to oh2 not.

the problem is the same with the other 5 channels (short and long).

best regards

1 Like

Hi again.

Today i tried to install the water detector HM-Sec-WDS-2 from homematic.
It seems i have the same problem with that device.
No update of the STATE channel in OH2 (water or dry).
But when i config a direct connection (within homematic-ui) with a lightswitch or whatever, the light turns on when the water sensor gets wet and turns off again when i gets dry again.
as i did it with the 6-channel-button-device from my post above, i also switched AES of for the water sensor (within paper-ui) and tried it again. all the same.

so thats it for this year.
maybe 2017 somebody can help me with tipps or a work around.

best regards and a good new year!

Today i managed the water detector:
Within Homematic-UI i disabled the “secured” option for HM-Sec-WDS-2.
And the STATE channel in OH2 is a String and not a Switch Item (i saw 3 states: dry, humidity and water…but the last few tests i only got dry or water…maybe more tests bring humidity up again but thats not that important for me.)

The issue with the 6-channel-button-device still is the same (for that device i also switched off “secured” in Homematic-UI but the problem stays the same as i described in my first post):
Clicking on the OH2-Item trigges the rule, pressing the physical button on the device (short or long) and the rule does not trigger (but the direct connected light does in both cases).
Maybe the ON time is to short on the physical side so OH2 never recognizes that?