OH2 FHT binding: Unknown message: FHT

After I have got the FS20 and HMS binding to work, I’m struggling since weeks with the FHT binding :joy:. I would appreciate it if somebody can give me a hint on how I can get this to work. It seems that the binding cannot resolve the messages received by the CUL.

Here is my config:

OH2 on Windows 10 with CUL V3 Firmware V1.66, org.openhab.binding.fht-1.9.0


Number RREGFlurDesired “EG Flur Soll-Temp. [%.1f °C]” (gHeizung) { fht=“housecode=061c;datapoint=DESIRED_TEMP” }
Number RREGFlurMeasured “EG Flur Ist-Temp. [%.1f °C]” (gHeizung) { fht=“housecode=061c;datapoint=MEASURED_TEMP” }
Number RREGFlurValve “EG Flur Ventil [%.1f %%]” (gHeizung) { fht=“housecode=061c;address=00;datapoint=VALVE” }
Switch RREGFlurBattery “EG Flur Heizung Batterie [%s]” (gHeizung, gBatterie) { fht=“housecode=061c;datapoint=BATTERY” }

sitemap default label=“Hauptmenue”
Frame label=“Geräte”{
Text label=“Heizung” icon=“heating” {
Frame label=“Raumregler EG Flur”{
Setpoint item=RREGFlurDesired minValue=6 maxValue=30 step=0.5
Text item=RREGFlurMeasured
Text item=RREGFlurValve
Text item=RREGFlurBattery


2017-03-01 19:42:55.154 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'chromecast.items’
2017-03-01 19:42:55.208 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'fht.items’
2017-03-01 19:42:55.223 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'fritzboxtr064.items’
2017-03-01 19:42:55.239 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'fs20.items’
2017-03-01 19:42:55.239 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'hms.items’
2017-03-01 19:42:55.239 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'yahooweather.items’
2017-03-01 19:42:55.254 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'yamahareceiver.items’
2017-03-01 19:42:55.840 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'default.sitemap’
2017-03-01 19:42:56.756 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at /start
2017-03-01 19:42:56.994 [INFO ] [basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app
2017-03-01 19:42:57.041 [INFO ] [assic.internal.servlet.WebAppServlet] - Started Classic UI at /classicui/app
2017-03-01 19:42:57.141 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
2017-03-01 19:42:57.826 [INFO ] [b.core.service.AbstractActiveService] - FritzboxTr064 Refresh Service has been started
2017-03-01 19:42:57.957 [INFO ] [ui.habmin.internal.servlet.HABminApp] - Started HABmin servlet at /habmin
2017-03-01 19:42:57.980 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
2017-03-01 19:42:58.226 [INFO ] [b.core.service.AbstractActiveService] - FHT Refresh Service has been started
2017-03-01 19:43:12.927 [INFO ] [nhab.binding.hms.internal.HMSBinding] - device: DD30, T: 5.7, H: 0.0, Bat.: ok
2017-03-01 19:43:27.008 [WARN ] [nhab.binding.fht.internal.FHTBinding] - Unknown message: FHT 2F63: 82=24

2017-03-01 19:44:26.228 [INFO ] [nhab.binding.hms.internal.HMSBinding] - device: EC8B, T: 16.0, H: 50.9, Bat.: ok
2017-03-01 19:44:31.059 [INFO ] [nhab.binding.hms.internal.HMSBinding] - device: 876F, T: 21.3, H: 33.9, Bat.: ok

Thank you in advance.

Addition: I have also several “Received unknown FHT command:” entries:

2017-03-01 20:10:02.663 [WARN ] [nhab.binding.fht.internal.FHTBinding] - Received unknown FHT command:

Sending commands (DESIRED_TEMP) works fine. Receiving commands not (ends up with above mentioned logs).

What devices are you using the FHT binding with? I use it with FHT80B radiator valve controllers without problems in OH2.

Thanks for your quick reply.
I am also using several FHT80b. How did you install the binding and which version do you use? Do you use the same configuration than I do? I tried to register the FHT80b by selecting “nA” within the function “CEnt” in the FHT80b device. Is there anything else I have to do to make it work?

All my FHT80B devices are configured like this:

Number HeatingBlueroomDesired           "Blueroom Desired-Temp. [%.1f °C]"      (Heating, logger)       { fht="housecode=3D4E;datapoint=DESIRED_TEMP" }
Number HeatingBlueroomMeasured          "Blueroom Actual-Temp. [%.1f °C]"       (Heating)               { fht="housecode=3D4E;datapoint=MEASURED_TEMP" }
Number HeatingBlueroomValve             "Blueroom Valve [%.1f %%]"              (All_Heating_Valve)     { fht="housecode=3D4E;address=00;datapoint=VALVE" }
Switch HeatingBlueroomBattery           "Blueroom Heating Battery [%s]"         (Heating, Battery)      { fht="housecode=3D4E;datapoint=BATTERY" }

I didn’t have to change anything on the devices themselves (the thermostat and the valve controller) to make it work. I had them working independently before I installed the CUL USB device and openHAB.

I’m using a snapshot version of the FHT binding from a few weeks ago that I downloaded from cloudbees.

Your item config looks like mine. How does your fht.cfg look like?
To install the binding I only copied the binding to the addon folder and added the config files. Is there any additional step I have to do to install the fht binding?

I fixed it. The housecode is case-sensitive. I changed “housecode=061c” to “housecode=061C” and it worked.
Anyhow, thanks for your support.