OH2 Habmin: How to do a manual Z-Wave network heal?

I am running OH2 stable and would like to do a manual Z-Wave network heal - but I don’t find this in Habmin…
Is a manual Z-Wave network heal possible? How?

…One additional question: What is “Synchronize network” in the advanced settings for the Z-Wave serial controller?
Maybe I am missing the documentation for Habmin?

1 Like

Background for the manual Z-Wave network heal request:
I have a battery operated sensor (NorthQ ZWave NQ-9021 Power/Energy meter) that normally sends every 30 min.
After an OH2 restart, it stops sending until auto-network heal at 2 am in the night.
Since OH2 is restarted pretty often (debugging, new features, updates,…), this is quite annoying.
Any idea?

Are you sure?

Currently there is no 2am nightly heal in the master version of the binding :confused:. A partial heal is done when the binding starts, but not after this at the moment.

This is different in the development binding so maybe you are using this?

I am using the official OH2.0 release and corresponding Z-Wave binding.
I am not sure that an auto-network heal at 2 am in the night is performed, but that is what I see in the Habmin settings for the Z-Wave serial controller - and from approx. 2 am, the northq device is sending data again…

My guess is that it’s not related to the heal unless you have a log that shows otherwise as I’m pretty sure there is no 2am heal in the OH2 release.

Okay, I will have a look at this again.

Is there a way to initialize a network heal manually?
Im having trouble keeping a remote Sensative strip in the netowk. He does not survive long enough for the 2 AM heal to run.

There are routing devices in the path to controller, but at the time of heal start, my strip is alread “Not found in Z-wave network”

How do i trigger a heal manually? Cant find any option for that in Habmin or PaperUI. I “think” i saw an option for it in an older release. Currently im running 22-SNAPSHOT with latest Z-Wave development binding.

Use HABmin.
Click on Configuration
Click on the Things Area.
Select a Node.
In the Upper Right Corner of the right pane, click on the Tools Dropdown. Select Show Advanced.
Click on Tools again. Heal the Device should be now available.
Go wake the item up. Turn it ON/OFF, OPEN/CLOSE.
You should see a bunch of Nodes being tested and logged.

You might need to look at adding a repeater. The heal probably won’t help since routing should work in any case.

Good luck…

I already have 3. Just realized that the “Heal Device” do not show for Things that are “Node not found in Z-Wave network”.

Anyone have a clue what a green node with a red outer circle means?

1 Like

Where is this displayed? In the things list or somewhere else?

In the Z-Wave network viewer.

There are full green nodes, full red, and green nodes with a red edge.

Green node means the node is online, red node means it’s offline, and the red border (I think) means it’s not listening (ie it’s a battery device).

I’ve had some great luck using Zensys Zwave Controller application - it’s a free download that allows you to heal or update each nodes neighbors plus it has some great other options like Network inclusion which has worked great for me.

I use this with the Gen5 stick.

You can download the Zensys tools from the following link:

Alternate Link:

Just note, you need to shut OH down and then connect Zensys - once complete you need to shutdown Zensys and then reopen OH.

Hope this helps!


It’s worth noting that this shouldn’t impact on routing. Routing is handled by the controller and each call made by the binding has an option set that allows routes to be discovered if they are not known or the initial route fails.

The heal will update the neighbor list which will look nicer in the diagram though.

I think this
TODO: Implement Application Update Request Handling of New ID Assigned (64).
Has something to do with Z-wave actors that cannot be found in the z-wave network.
Ive got a switch which has a hard time being discovered in the network. When it’s offline or communication problem, I’ve got this (64) message in the log.
When it’s online the message does not appear.