OH2 Homematic : No Things for Temperature Management

Hey there,

just starting to give OH2 with Homematic a try.

I installed the binding and lots of Things appeared in my Paper UI. But there are no HM-CC-RT-DN (Electronic Wireless Radiator Thermostat), HM-CC-TC (Electronic Wireless Radiator Thermostat) or
HM-TC-IT-WM-W-EU (Wireless Room Thermostat) Devices recognized.

What could I do that Paper UI finds this THINGS ?


Install the Homeatic Binding and create a Gateway to the CCU, Then OH should find your thermostats.


Hmm - i installed the homematic binding by using paper ui (simple clicked “install”).
My window contacts, switches etc. are all discovered as THINGS - but no temperature THINGS appear in the Paper UI inbox…

Do you understand what i want to tell?

Hi Dominic,
I had a similar experience with the wireless room thermostats. In the end I somehow solved the issue by installing the latest Oracle Java Version.

Hi Chris,

thanks for replying - but a “sudo java -version” gives me:
java version "1.8.0_65"

This should be the latest version.

Anyone else who could give me a hint?

Not sure, if upgrading the java version helps, but the last java-version is 1.8.0_101.
Unfortunately it’s not in the Rasbian-Repo right now.

If you’re on a Raspi (Rasbian), then have a look here how to upgrade.

Thanks Peter - now i´ve

java version “1.8.0_101”

But the issue is still there - no temperature Devices are discovered as things.

Anyone else?

I have some HM-CC-RT-DN , they were discovered without problems (… and i’ve set up OH2 multiple times :slight_smile: ) and working flawlessly

EDIT: Did you try a manual rescan? Otherwise maybe deleting the homematic-binding and readding would help, but its just a guess.

hmm… strange. I deleted the binding and added it again - but that did not help :frowning2:

It´s frustrating

Just some systematic questions that came into my mind and may help yourself or others to solve the problem:

  • On what system is openhab running?
  • Which openhab build (B3 or recent nightly), how installed?
  • Which homematic (CCU2 ?)
  • Recent firmware on the homematic? (recent firmware on the HM-CC-RT-DN)
  • Are the HM-CC-RT-DN 's (and the other stuff) you’re missing accessible through the homematic-GUI? Stable connection?
  • Did you name the missing Items with special national chars like “äöü” oder accents on the homematic?
  • OH-System rebooted before a manual scan (… just in case …)

And probably the most important question: What does the OH log say when you do a manual scan on the homematic binding.

Hi Peter,

I now checked the log and for really there are errors for the heating devices:

2016-08-30 09:38:58.287 [WARN ] [ternal.communicator.HomematicGateway] - Can't load device with address 'KEQ0729410' from gateway 'fa3c6e4d': Ung?ltiges Byte 1 von 1-Byte-UTF-8-Sequenz. 2016-08-30 09:38:59.250 [WARN ] [ternal.communicator.HomematicGateway] - Can't load device with address 'LEQ0002140' from gateway 'fa3c6e4d': Ung?ltiges Byte 1 von 1-Byte-UTF-8-Sequenz.

Do you know what OH2 does not like here?

Probably @gerrieg is the right man to shed some light in there.

I had the following experience with OH2 and the temperature sensors:

  • OS X: everything OK
  • Rpi3 on first attempt with OpenJdk: not successful
  • Win 10 laptop: not successful with Oracle Java (don’t have the version number at hand)
  • Rpi3 new attempt with new system and Oracle JDK from Oracle website: discovery successful
  • NUC running Ubuntu 16.04 and Oracle JDK: running successful.

However, since you have already tried the latest Java version it has to be something else. I used to have the exact same warnings in my log.


Please switch the binding into trace mode:
<logger name="org.openhab.binding.homematic" level="TRACE" />

and send me a full startup log file

Hi Gerhard,

i sent you an email with the full log. I wrote the mail in german - i hope this is okay for you.

Hope it helps to find out, what´s going wrong here…

Greetings Dominic

Hi everybody,

after analyzing the trace-logs the error could be identified as an encoding error.

But it was not an error in the binding but in my linux-system. The LOCALES where not set correct.

I did a raspi-config and set the LOCALES only to “de_DE.UTF-8”

After a reboot everything was fine and the THINGS where recognized.

I hope this helps for others too.

@Gerhard: Thank you very much for the great support.

Greetings Dominic

This was indded the case :slight_smile:

Just wanted to thank you - that worked great.

I nearly gave up investigating this issue.