OH2 KNX 1.9 Binding - read from KNX results in a write

I am experiencing this now as well. I am on the most recent OH 2.2 stable.
Every time OH2 reads the Set-Temperature of my heating actor, it writes back the default value. So if default is 20.5 and current value is 22, after the read it is back to 20.5. This drives me nuts.
Autoupdate true or false does not make any difference. Unfortunately, this actor accepts writes on a status item (MDT). So while other devices separate clearly between input and output GA, maybe this is the reason why it only affects this device.
Am I wrong or is there really no way to define an item explicitly as read-only? The “<” in front of a GA indicates only, that this GA needs to be read on startup, but to my understanding this is not a read-only-flag. Correct?

Any ideas welcome

Correct. “<” send response to bus. And IF actor output programming for UPDATE and SEND then it send current value to bus.
But actor must resend NEW value set temp, because OH2 write new value before. Do you may say art. no for actor, I look in ETS…

I am using an MDT AKH-0400.02

Ah, solved it by accident :slight_smile:
It seems, as long as there are two GA linked to the item (one to write and one for the status), this does not appear anymore. Additionally, it was not the Set-Temp object but the HVAC-Mode that caused the trouble. So every time OH2 reads the HVAC Mode State, it writes back the same state. As my actor sets the default temp when changing the HVAC mode, it always went back to the standard temperature. Now I am using a separate HVAC-State-Item (GA) and everything works as expected (discovered this by accident, as I obviously had this item still active during my tests, must have been copied it accidentally).

Guess it would be great if we coulf have an option to specify an item as read-only explicitly.

Have a great one

Edit: Seems I have been too quick. It’s not reliable. Sometimes OH2 does not repeat messages, sometimes it does, despite the separat GA and object for state.

Edit 2: Seems a reboot of OH2 fixed it…let’s see for how long.