OH2 - Massive problems with Bundles installation. Installation issues

Hello,
I have to notice to the Devs massive problems I encountered with boundle installation.
I’m starting with a brand new debian release. corretly installed and updated

what i see in my sistem is the following things:

  1. sometimes 1.9 binding gives error during installation

[ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing “ANY 1.9 BINDING”

Only solution I found is to remove OH2 and reinstall.

  1. sometimes all seems OK from the files. Karaf console don’t give any problem BUT 1.9 bindings, like MQTT and Wheather, wont work properly

Only solution I found is to remove OH2 and reinstall.

look at 2 posts solved by me, only re-installing OH2. any other way was unusable,


Please Dev, can we try to open a correct issue about these waired behaviur ???

There is nothing stopping you from opening an issue yourself if you are not seeing one that addresses your issues.

Same issue for me since i’ve upgraded from recent snapshot to final release but with thé HTTP binding

yphyph01 I thought since1 week about these problem and maybe I solved out the mistery!!

I wanna explain you my tought:

OpenHab2 for install 1.9 binding NEED to create some files inside /etc/openhab2 directory; The default owner and group is openhab:openhab.

One of the first action I (and maybe you also) made is

sudo chown -hR mylinuxuser:mylinuxuser /etc/openhab2

Because I need to edit Items and Sitemap from another PC!!!

These Action prevent Openhab2 to create the 1.9 binding relative files inside /etc/openhab2 folder…and give out missing of installation and several binding errors

Try out these before install

sudo chown -hR openhab:openhab /etc/openhab2
And in the other folders you change the ownership.

Install the binding and all you need and only at the end come back to
sudo chown -hR mylinuxuser:mylinuxuser /etc/openhab2

Please let me know if I’m right or not!