OH2 Netatmo Outdoor and Indoor Module not work

i have a problem with my Netatmo Binding2.
The main module works because all values are displayed correctly.
The outdoor module and the second indoor module unfortunately do not indicate anything.

I have already created a new app at Netatmo, problem persists.

2017-01-29 11: 47: 29.467 [ERROR] [netatmo.handler.NetatmoDeviceHandler] - Exception when to update to channels: null

OH2 installed yesterday (28. January)
Could anyone help me, please? Thank you

I had this when one of my modules lost connection to the main station, did you check if your modules are properly connected and deliver values to the main station ?

all modules are connected. UI -> Things are all online.
With OH1 it functions perfectly, only not with OH2

OH1 Netatmo binding works with OH 2.

But I want to use the OH2 binding :slight_smile:

I’m using version 2.1.0 snapshot of the binding, and it works fine. Just a guess - What happens when you search for new netatmo things ? furthermore you might try to turn on debugging for the netatmo binding. in some other cases it also helped me to delete cache and tmp directories of openhab, you might try this too.

How can I update the netatmo binding to 2.1.0?

Add the following line
echo ‘deb http://dl.bintray.com/openhab/apt-repo2 unstable main’ | sudo tee /etc/apt/sources.list.d/openhab2.list

sudo apt-get install openhab2
sudo apt-get install openhab2-addons

Unfortunately, the netatmo sensors do not work. Only the main sensor is displayed.
There seems to be a bug in the Netatmo addon

Thank you

Netatmo binding 2.1.0 does not work unfortunately also :frowning:

Sorry, that was misleading - I am using Netatmo binding with openhab 2.0 since quite some time, i think one of the very first beta releases. I just wanted to comment on @ranielsen who proposed to use OH1 binding.

I dont have any issue with Netatmo, all my modules work fine - Did you try these i mentioned above, turn on debugging, delete tmp/cache, perhaps searach again for netatmo modules ?

I do have the same issue @StevenFD is describing. Multiple tries in various ways to get it working (clean installation, text-based thing definition, discovery through paperUI) - none of them worked.
I also reset the credentionals on the Netatmo App Website, again no change.

Station data is available, but for the other modules I receive the same error as @StevenFD

Does anyone have a clue? Is anyone working on the issue? Anyone else has the same issue?

Many thanks for your help

Hi James,

With me unfortunately still the problem, I am currently working with the 1.9.0 Addon. That works at least.

Find it just too bad, the 2.0 Addon does not work. Hopefully, the problem will be fixed soon.

Hi, colleagues,
is this fixed now? I seem to have the same problem.
Using openHAB 2 and as a newbie I tried all in the PaperUI without manual configuration in files.
The NetAtmo main station shows in the control page correctly, but the outdoor, additional indoor and rain station are existing but does not show any values.
In the original NetAtmo iOS app everything is fine.
In the PaperUI Things view every thing is online.

Another problem I have is when I try to edit Things in the PaperUI. For example edit the Location field. The save button is disabled because it reports the module id and device ids are wrong.
My value is 02:00:00:02:93:91 and it says "Input should satisfy expression \p{XDigit}{2}:\p{XDigit}{2}:\p{XDigit}{2}:\p{XDigit}{2}:\p{XDigit}{2}:\p{XDigit}{2}"
The values were filled by auto discovery. Why are they wrong? Is this the source for not working?
Thank you in advance, regards,

Dear Thomas,

Yes, this is fixed in the snapshot version. The fix is not part of the latest stable.

Dear Christoph,
thank you for your fast answer.
Best regards.