OH2 on QNAP - what is the best way?

Hi there OH2 community!

I found different discussions about installing OH2 on a QNAP.
I want to find the best way to install OH2 on an Intel-QNAP. I tried a Linux-VM, but i can’t access the Z-WAVE-Stick or my Arduino to communicate with my 433 MHz-Devices.

What is the right way?

  • Linux-VM?
  • Docker-Solution?
  • OH2-QPKG?

I think the main-problem is accessing the USB-Devices?

Karl Heinz

I used it on a Linux-VM and QNAP TS-453a. You can connect the USB-Device to the virtual machine. The problem is sometimes the reconnect after restart the Nas. I bought an mytun-50a box to connect the usb-devices and it is working 100% stable with it.

Hi Frank,
i am using a TS-453mini with an Ubunut VM, but the Aeon Z-WAVE-Stick can not be found by the QNAP and consequently not found by the VM. I read about the mytun-50a box. It sounds good, but not inexpensive.

I’m running Ubuntu on a VM on my TVS-671, very happy with it. So far I have not connected anything to USB, but have a aeon zwave stick and a plugwise stick which need connection, i thought it should be easily possible ?

@kallecux, @frankz: what issues exactly were you facing with USB in the VM ?

It is not possible to access the Z-Wave Stick via USB.

ok, i just tried it myself - plugged both USB sticks into my QNAP and try to “mount” them to my VM, it seems only the plugwise stick is recognized by the QNAP while the Aeontec lacks kernel drivers, at least that is my understanding - Did you ever try to compile the drivers yourself or such ?

Hi Max1968 - i think that the QNAP does not need a driver for the Z-Wave Stick. It should only pass through.

it is working fine for me (seems the plugwise stick was not recognized). Have you “connected” the zwave stick to your virtual machine like here under “USB”, 3-1-8 is my zwave stick ?

Sorry! My mistake! The stick MUST be connected to an USB 2.0 connector. I have overseen the 2 USB 2.0 slots. Now it works.
Thanks for your help!
Have a nice weekend.

thanks to you, in fact exactly this was the reason why my plugwise stick didnt work… I have now both sticks connected to USB2.0, and both work…

How do you solve the problem when rebooting the QNAP. The USB-Allocation is reset. Right?

i havent tried it yet, i rarely reboot my qnap - in case it bothers me too much i might think of this usb server as well, but it is a bit expensive…