OH2 setpoint value not updated via Knx

Hi there, I got a problem with a setpoint value

For the following configuration my setpoint value is never updated on the basic or classic ui via Knx bus event.


Number Temp_SOLL_EG_Buero                         "Soll Temp. Büro [%.1f °C]"                        <temperature>            (gTemp_SOLL, EG_Buero)            {knx="<0/5/70+0/4/70"}


Setpoint item=Temp_SOLL_EG_Buero label="Soll-Temperatur [%.1f]"


2017-01-10 20:04:20.173 [ItemCommandEvent          ] - Item 'Temp_SOLL_EG_Buero' received command 19.0


2017-01-10 20:04:20.155 [TRACE] [g.knx.internal.dpt.KNXCoreTypeMapper] - toType datapoint DPT = 9.001
2017-01-10 20:04:20.162 [TRACE] [g.knx.internal.dpt.KNXCoreTypeMapper] - toTypeClass looking for dptId = 9.001
2017-01-10 20:04:20.164 [TRACE] [.binding.knx.internal.bus.KNXBinding] - Added event (item='Temp_SOLL_EG_Buero', type='19.0') to the ignore event list
2017-01-10 20:04:20.172 [TRACE] [.binding.knx.internal.bus.KNXBinding] - Received command (item='Temp_SOLL_EG_Buero', command='19.0')
2017-01-10 20:04:20.173 [TRACE] [.binding.knx.internal.bus.KNXBinding] - We received this event (item='Temp_SOLL_EG_Buero', state='19.0') from KNX, so we don't send it back again -> ignore!
2017-01-10 20:04:20.184 [TRACE] [.binding.knx.internal.bus.KNXBinding] - Processed event (item='Temp_SOLL_EG_Buero', type='19.0', destination='0/5/70')

This configuration have worked fine in OH1 but won’t with OH2.

Is there anybody out there, who could help to solve this problem?

Looking forward to your reply.


Dear Christian,

could you additionally describe the values and dpt which you expect on 0/5/70 and 0/4/70? 0/5/70 receives commands, e.g., the target temperature, while 0/5/70 receives the status from the actuator, right? Why do you send a read request on the first address using “<”?
Did you try to remove the label from the sitemap and use the default one from the items definition? And also add some minVal / maxVal / step values?

Setpoint item=Temp_SOLL_EG_Buero step=0.5 minValue=1 maxValue=30

Unfortunately, I’m not familiar with the KNX log information, but it seems that there is an issue with the addresses? I’m sorry but I’m just guessing as I’m not that familiar with the OH2 architecture yet.



I’m not sure whether it’s a knx binding issue or an ui issue. As I mentioned, exactly that items/sitemap definition works fine in OH1. As you can see in the events.log the value is received from knx bus and the item value is updated. But the setpoints label is never updated with the value.

I think DPT 9.001 is correct to hold temperature values. The group address 0/4/70 is used to set the target temperature where on 0/5/70 I can read the current target temperature. This is why I read with <0/5/70.

I also tried to remove the label from the sitemap without success.
I also tried to add the parameters as @robin.muellerbady mentioned without success.

Any ideas?


Hi guys,

I also stumbled over this and found this thread.
After reading, that a restart could fix it I just tried it … and it worked … I´ll have a close watch now just h ow long it will work, but for now …:slight_smile:

UPDATE: It stopped working after I refreshed the items/sitemap over SmartHomeDesigner (i think, at least, that was the cause)

Now I have toi hit F5 again to refresh the value (but the value itself is ok and gets transmitted to KNX)

UPDATE1 : CONFIRMED - a update of the items/sitemap structure breaks it …
UPDATE 2 : CRAP … no, it doesn´t really … :frowning:

same thing here. Using latest openHAB 2.2 openhabianpi.
I can see in the console with smarthome:items list … that the Items have the correct state, however in none of the UIs it is rendered correctly. After refresh most of the time the data is rendered, but not always. A restart of the openhab2 service did not help.
Edit: not quite true, using the openHAB App on an iPad, the refresh works fine. So I assume the problem lies in the Webkit emulation?

Hi, had the same problem. Works in IE not in chrome or Firefox

Did anyone find a solution to this? I have the same issue but my setpoints are blank in any browser.

Currently i encounter the same problem. UI is not updating. running on openhab 2.4.0

I encountered the same issue (setpoint values are sent but not updated in the clients (web / android)). I found another thread, where someone had a sitemap with a different name than “default”:

Renaming the file back to “default.sitemap” fixed the issue for me.

So maybe the clients event callback registration does not work with non-default sitemaps?