OH2 shows up as "not supported" in Homekit on iOS (after successfull pairing)

Hello everybody,

I’m new to OpenHAB and installed OH2 Beta4 on my Linux machine yesterday for testing purposes. But I cannot establish a proper Homekit connection. I installed and configured it using the Paper UI GUI. At first Homekit didn’t find OH, but after I added the ip-address parameter to the Homekit Integration service and restarted OH2, I was able to see OH from the Homekit app and successfully pair it. But on the bottom of the OH device-icon is written “Not supported” (“Nicht unterstützt” in german). When I tap and hold the icon a screen opens which tells me that “This device is currently not supported by the Home-App”. I am using the latest version of iOS (10.1).
Do you guys have an idea what’s going wrong? Is there a known issue?

Thanks in advance for your help!


That happened to me when I configured the bridge but I had no items tagged for HomeKit.

Hi jjmeseguer,

thanks for your answer. How can I tag items for Homekit?
I’ve set up a simple config with just a simple switch with no real hardware connected:


Switch Light_Test          "Light Livingroom"


sitemap Haus label="My Sitemap"
    Frame label="Test" {
        Switch item=Light_Test

Where do I have to add those “tagging”?


Found the answer myself. On this page https://github.com/openhab/openhab2-addons/tree/master/addons/io/org.openhab.io.homekit you find examples for how to add Tags. For my simple single lighting switch I editied the house.items like this:


Switch Light_Test          "Light Livingroom" <light>      [ "Lighting" ]

The last parameter is the “Homekit Tag”. Nevertheless, I had to rebind OpenHAB2 to my iPhone. I also cleared the pairings “openhab> smarthome:homekit clearPairings” and set “openhab> smarthome:homekit allowUnauthenticated true” to be sure that these aren’t the problem. Afterwards I restarted OH and successfully paired the devices and can see my switch in Homekit.


I did everything mentioned above and still get “Not supported” in the OpenHAB bridge item after successfully pairing.

I taged a few devices in my .items file with [ “Lighting” ] but do not see them in HomeKit :rolling_eyes:

Anything I can do?

I have the same problem. I use a file .items but if I add at one light the tag [“Lighting”] I have the string “Not supported”.
If I create a new .items file, the error are the same.
Is there a solution without delete my personal items files?

Ok I solved it moved the item that homekit use at first of .items file

by moving the item to the top, it worked? that seems odd. Homekit used to work fine for me, but now I’m getting Not Supported. Even with items tagged correctly.

Yes @russell, the first element of my items are the thinks that I included in homekit. The next elements are incluted only in sitemap and in this case homekit works.

Hello all,
I have the same issue. I inserted these 2 items at beginning of my .items file:

Switch  SwitchGarage <blinds>  [ "Switchable" ] {mqtt=">[HOME_IVAN:openhab/garage:command:ON:default],>[HOME_IVAN:openhab/garage:command:OFF:default],<[HOME_IVAN:openhab/garage:state:default:.*]"}

Switch  SwitchGate <garagedoor> [ "Switchable" ] {mqtt=">[HOME_IVAN:openhab/gate:command:ON:default],>[HOME_IVAN:openhab/gate:command:OFF:default],<[HOME_IVAN:openhab/gate:state:default:.*]"}

Could you help me to solve this issue?

Hi Ivan,

I’ve the same issue. Seems to me that the issue start coming when some items have the {} binding section.
Did you solved?

Same problem with {} sections here. Simply adding:

{ autoupdate="false" }

to the end of any HomeKit-tagged item causes the whole HomeKit integration to fail and appear as Not Supported in the Home app.