OH2 Z-Wave refactoring and testing... and SECURITY

security
zwave
Tags: #<Tag:0x00007f6ce59e59e0> #<Tag:0x00007f6ce59e5850>

(Chris Jackson) #2431

This is not correct - high power mode should normally be used although either will work just fine. High power mode is the recommendation though.


(Chris Jackson) #2432

I’ve just updated the database so hopefully this will be fixed after the next update (tonight if I get some time today to do everything I need to get done :wink: ).


(Marcin) #2433

Thank You, It has helped (I have edited jar file and added “type=TEMPERATURE” :slight_smile: ).


(Chris Jackson) #2434

Ok, thanks. So you mean it is now working with this change? :slight_smile:


(Marcin) #2435

Yes, It is working.
I have exported xml from database (after your change), edited qubino_zmnhbd_0_0.xml in zwave binding jar file and voila: :slight_smile:

 NODE 46: Got a value event from Z-Wave network, endpoint = 3, command class = COMMAND_CLASS_SENSOR_MULTILEVEL, value = 1.1
11-lut-2018 16:17:41.973 [DEBUG] [.internal.converter.ZWaveMultiLevelSensorConverter] - NODE 46: Sensor is reporting scale 0, requiring conversion to 0. Value is now 1.1.
11-lut-2018 16:17:41.974 [DEBUG] [wave.internal.converter.ZWaveCommandClassConverter] - Converted temperature from 1.1C to 1.1C
11-lut-2018 16:17:41.974 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 46: Updating channel state zwave:device:9c9f18d3:node46:sensor_temperature3 to 1.1 [DecimalType]
11-lut-2018 16:17:41.974 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - NODE 46: Commands processed 1.

(Chris Jackson) #2436

Perfect - thanks for the feedback :slight_smile: .


(paulfaure) #2437

Hi All,
I am trying to add my zwave things into OpenHab 2.2.

Running one of the latest snapshots of the zwave plugin:

openhab> bundle:list | grep ZWave
246 │ Active   │  80 │ 2.3.0.201802081624     │ ZWave Binding
openhab>

Thing configured like this:

Bridge zwave:serial_zstick:cont "ZStick" @ "Home" [
  port="/dev/ttyUSB0",
  controller_softreset="false",
  controller_master="true",
  controller_inclusiontimeout=300,
  heal_time=5,
  heal_enable="true",
  security_networkkey="....."
]
Thing zwave:aeon_dsc06_00_000:cont:node3 "ZWave Node3" (zwave:serial_zstick:cont) [node_id=3]

My Error is:

2018-02-11 15:43:07.638 [ERROR] [ding.zwave.handler.ZWaveThingHandler] - NodeID is not set in zwave:aeon_dsc06_00_000:cont:node3

I have seen tonnes of different formats for the .things file. Is what I have the latest version for the 2.3 development branch?

Thoughts?
Many thanks.


(vossivossi) #2438

To be honest I do not know. But I let OH discover and configure the things, while I take care of items, sitemaps and rules with files. This works fine. Would this be an approach for you too?


(paulfaure) #2439

I had that originally, and it worked. But I find it hard to maintain the configurations in a UI. Much easier to change it in a text file if I am doing multiple changes.


(SiHui) #2440

Why would you do multiple changes on a single controller :rofl:

I also tried the manual thing configuration a while ago, but then realized that all config parameter changes have to be done via text file which can be a mess. No more easy config change for devices via PaperUI or HABmin.

So I went with @vossivossi approach and this works fine since almost two years.


(Chris Jackson) #2441

You realized slightly wrongly…

Config parameter changes can not be done by openhab at all if you use text files. The binding only configures devices when it receives a configuration update, and the REST interface blocks these when the thing is manually configured.

See the recent discussion here -:


(SiHui) #2442

Maybe I used the wrong term :sunglasses:

What I meant is for example changing the invert_percent config parameter for a rollershutter from false to true like:

Thing zwave:fibaro_fgrm222_24_024:controller:node11 "Z-Wave Node 11: FGRM222 Roller Shutter" (zwave:serial_zstick:controller) [ node_id=11 ] {
	Channels:
Type blinds_control : blinds_control [ config_invert_percent="true" ]
}

Or did that stop working too?


(Chris Jackson) #2443

No - these parameters you can set in the config files - it’s “just” the configuration of the device that you can’t do at all…


(Kendall) #2444

Oh, sorry. I guess I didn’t think to check the documentation since you have to have the newest, “unstable” version in order to get all of the security features (from my understanding). I assumed the documentation was only updated to the stable version. My mistake.

I actually am planning on trying to contribute some PRs in the future, once I get the hang of OH2; there are still a bunch of features that I know nothing about. And I need to brush up on Java; I haven’t worked with it in 8 years.

But anyways, thanks for all your contributions! They are much appreciated!


(Kyle Corsi) #2445

Hello, during my testing of the February 8th build is that my front door lock is not recognized as a lock. It is recognized as:
Z-Wave Node 002 (0109:2006:0621:19.6) and because of this has not features of a door lock. On the version of the binding that is available through the extension browser (either HABmin or PaperUI as version 2.2.0) sometimes it sees my door lock as a generic door lock. For the record if it helps I have a Z-Wave Deadbolt Door lock from MonoPrice.


(Chris Jackson) #2446

I guess it’s not in the database - the database will need to be updated before you will see the channels.

I’m not quite sure what you’re referring to, but probably you’ve seen the device class which is not linked to the device type itself. The device type is directly derived from the numbers you posted above.


(Kyle Corsi) #2447

I understand, I will follow the instructions for adding a new device to the database. Is the database compiled into the resultant binding jar file or is it accessed by the jar at runtime from somewhere. I.E will a new build be required to see database changes?


(Chris Jackson) #2448

The database is compiled into the binding itself, so once the database is updated, it’s reviewed, approved, exported and then compiled into the binding.


(Kyle Corsi) #2449

Thank you, Luckily it appears as though someone has started the process. For anyone who also has this lock you can follow the progress that someone else started.

http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/301

Although it notes that it doesn’t support security. But as a door lock I was pretty sure it did otherwise it would have been possible to set lock codes with other builds of this binding. I can upload my XML file for consistency as an up-to-date version although I’m not currently allowed any database edits.


(Chris Jackson) #2450

I suspect that the database was created by someone who hadn’t included it securely, so it doesn’t include any channels - or the secure tick on the box… Note that the tickboxes generally aren’t used by the binding, so not ticking security won’t impact anything - the binding will work all this out by itself.

Please can you upload your xml file to this entry and hopefully it will sort things out…