OH2 Z-Wave refactoring and testing... and SECURITY

security
zwave
Tags: #<Tag:0x00007f1829ba3540> #<Tag:0x00007f1829ba32e8>

(Kyle Corsi) #2451

I will request edit rights through email and then upload the xml file I have.

Thanks


(Chris Jackson) #2452

It’s ok - I’ve found you in the system so will update your access in a few minutes… (sorry - didn’t realise you didn’t already have access).


(Kyle Corsi) #2453

Thank you. Now I just need to find {userdata}/zwave on Ubuntu server


(Kyle Corsi) #2454

Thank you for the help, I’ve submitted the XML that I have although I wasn’t able to change the setting regarding SECURITY. According to the manual attached to that device it does support it.


(Chris Jackson) #2455

Are you really sure that the device is securely included? In HABmin, is there a green tick next to the properties for security?

The XML doesn’t show any information about security, and doesn’t contain any of the command classes I would normally expect a lock to support (like the LOCK command class :wink: ).


(Scott Rushworth) #2456

The Vision lock has a different manufacturer number than the Monoprice, so they would need separate entries. But if you uploaded the XML, it probably is the Vision. The reference to Monoprice in the Vision db entry should probably be removed. I updated some of the command classes for you (had some other things to do in the db). The lock looks to support Association CC, but I didn’t see anything on the number of nodes supported or group ID, so I left it out. Strange that the manual doesn’t mention Association or some of the others. Some channels are still missing. Hope this helps!

@chris, something is funky with the db. I wasn’t able to add a channel for Battery, and I didn’t see this channel in any other devices (BE469, WADWAZ, WAPIR, etc.). Also, I updated to OH 2.3 snapshot 1212 and noticed that in both Habmin and PaperUI that the Association CC is missing from all of my devices. But I see it in the XMLs. Not sure if this was something new in 2.3.0.201802082157 and I hadn’t noticed, or the upgrade somehow messed something up, or if there’s something else going on specific to my system.


(Kyle Corsi) #2457

Thanks for responding! This is what it shows for me currently in HABmin:

@chris I can now confirm based on this screenshot it does not use security.

This is very interesting considering the numbers are all the same as the one pending in the database and that one’s manual says it does support SECURE.


(Scott Rushworth) #2458

It looks like you need to exclude and reinclude (close to the controller) to try and get it securely included. You’ll see the green checkmark when you do.


(paulfaure) #2459

If i let OH discover the “things”, can i stillcreate the links and items in txt files?


(SiHui) #2460

Yes.

Switch FibFGS222_DoubleRelay1_1 { channel="zwave:device:15ca6a108b9:node36:switch_binary" }

First part is the item, second part in curly brackets is the channel linked to the thing.


(Chris Jackson) #2461

Funky :wink:

You can’t add battery channels - they magically (should!) add themselves when the BATTERY command class is found.

The database has a list of command classes that are considered “user” classes and only these classes can have channels added.

What do you mean by “Association CC”? The command classes aren’t listed anywhere I can think of - do you mean the association configuration parameters? If so I don’t know why they would be treated any differently to any other parameter - HABmin and PaperUI don’t have any specific handling for these…

I’ll take a look tonight.


(Chris Jackson) #2462

ZWave devices will act differently depending on how they are included. It’s still the same device, but because it’s not securely included, it’s not presenting the secure command classes. You need to reset it, and try another secure inclusion.


(Scott Rushworth) #2463

Really? Man… I thought all those stories about magical channels were just faerie tales! This whole time I’ve been thinking all channels needed to be manually added. It’s all starting to make sense now! :mage: Maybe they could be a shimmery iridescent color, so we all know which ones are magical?!

Well… unless they are secret magical… :mushroom:

Yeah, the association configuration parameters for all my devices disappeared. This persists even after several OH restarts.

I bet you’re going to tell me now that these are magical too…


(Chris Jackson) #2464

:sunglasses:

This seems to be evil magic! I can’t see any reason why they wouldn’t be there - everything looks fine with the definitions


(paulfaure) #2465

So according to the code:


It should be "zwave_nodeid"
Alas, this still doesn’t work.


(Chris Jackson) #2466

Sorry, but this isn’t correct - you’re not looking at the right code. This feature is only available in the development version and you’re not looking at that version. You need to use node_id.

Please see the testing that was performed previously here -:


(paulfaure) #2467

Hi @chris i read the writeup and its well done. Followed it perfectly.
Unfortunately, “node_id” didnt work. nor did “nodeid”, “zwave_nodeid”, “zwave_node_id”. Also tried with and without quotes on the Number values (to make em strings and ints). Also tried upper and lower cases.


(Chris Jackson) #2468

I’m not sure why this is to be honest. node_id is what the binding is looking for, and it certainly used to work. The binding doesn’t know (or care) if this is specified in a file, or through the UI - it looks for node_id in any case. Clearly from the binding perspective, this is working or the binding simply wouldn’t work for anyone.

I’ll see if I can do a quick test…


(Chris Jackson) #2469

It seems to work fine for me.


(Scott Rushworth) #2470

I think this started after updating to snapshot 1212, and it doesn’t seem like anyone else is reporting it. I’ll try my archived version. Very strange!