OH2 Z-Wave refactoring and testing... and SECURITY

I’m on OH2 snapshot build 1218 right now. I tried 1221, but was getting some strange errors and rolled back.

Sorry - I proposed to change this limitation, but it was rejected.

@chris While using your March 4th binary several of my Aeotec DSC19 Micro Smart Energy Illuminator G2 units appear to be defaulting to their default configurations. I first noticed this yesterday after imaging a fresh Openhabian system, installing the March 4th Z-Wave binding linked in this thread, and moving my Z-Wave controller (Aeotec Gen5) to the new system. I noticed the DSC19s behaved as if settings were reverted to defaults, specifically parameter 120 (External Button Mode) and 80 (Status Change). Each of my DSC19s is wired to momentary press switches, though behaved as if set to the default setting of 2-way. What’s more interesting is that the config in HABmin shows the correct momentary press settings. Toggling the setting to 2-way and back to momentary press temporarily fixed my problem. This evening, approx 24 hours later, I’m finding at least one of the DSC19s parameter 80 (Notification on Status Change) behaved as if reverted to default (Basic CC) though HABMin showed it was set for Hail CC. After toggling to Basic and back to Hail, the DSC19 resumed sending Hail CC as expected. Nothing of interest that I can find in the logs. I’ll turn up logging verbosity so hopefully, I’ll have something concrete to share if it occurs again.

This is a little off topic for this thread, but where can I download older artifacts for 1218?
I have gone through this site top to bottom can can’t find the link.

Go to


and switch to the build you want:


I am probably missing something, but those builds don’t have the “Last Successful Artifacts” section for the actual download.
Does someone have the link to the OH .tar.gz file for build 1218?

Looking for help troubleshooting security inclusion. Running openHAB 2.3.0~20180307132030-1 (Build #1224) with a aeotec dongle added to OH as a Z-Wave Serial Controller (Z-Wave USB Stick with Serial Interface). I added the network key as a thing parameter when adding the Controller through HABmin . I’m able to add the entry lock (YRD210) I’m trying to control but I can’t control it.

START LEVEL 100 , List Threshold: 50
ID │ State │ Lvl │ Version │ Name
15 │ Active │ 80 │ │ ZWave Binding


log file

It’s included, but the red X next to Using Security means it was not securely included. Exclude (some locks may need a reset here too) and reinclude through OH from close proximity to the controller.


I’ve just started to use the updated binding on a test instance of openHAB with a Fibaro Dimmer 2 (FGD212).

I’ve added the device in secure mode and everything seems to be working except for scene activation.

I’ve enabled the scene functionality in the device and I can see the messages being sent by the device which then have security removed and the scene activation event successfully identified.

I can’t see any channel from the device for the scene number and any items I create don’t get any events.

As a test I reverted back to the 2.2.0 ZWave binding (with suitable restarts, new inclusions etc) and the scene notification events are sent.

Does anybody else have scene activation events working when using the Fibaro Dimmer 2 and security?


The device looks like this channel is setup in the database, as well as the other entry for firmware <= 3.4 that looks to not have SECURITY. Where you also deleting the Thing when switching bindings?

Yes, I deleted all Things when switching between the binding versions. I tried this security binding first before switching to the 2.2 version, and then back again.

Hmmm,… so, with the development binding, in the logs you can see the SCENE_ACTIVATION command class report come in, but there is no channel listed for scene_number. What do you see in the device’s xml (in userdata/zwave) for manufacturer, deviceId, deviceType, and is SCENE_ACTIVATION listed under NIF and endpoint 0? Of course, you’d need to be back on the dev version to check this.

Out of curiosity, did you try restarting OH?

I’ve been doing some more checking and it might be related to security, as I’ve tried starting afresh with 2.2, dev - no security option set and dev security all devices set. I’ve been deleting Things, excluding devices, restarting OH2 between each test. I can’t see the scene channel in any cases with the dev version.

In 2.2 xml file I see:

  • manufacturer = 0x10f, deviceId = 0x1000, deviceType = 0x102.
  • commandClass = SCENE_ACTIVATION

In dev xml file’s I see:

  • manufacturer = 0x10f, deviceId = 0x1000, deviceType = 0x102.
  • COMMAND_CLASS_SCENE_ACTIVATION in endpoint 0 if I’ve read the nesting correctly…

I can’t see NIF in mentioned in the xml files - is there a different term I should be checking for?


I think it’s called nodeInformationFrame in the XML.

The device is being identified correctly…

… and reporting the SCENE_ACTIVATION CC.

Sorry, I used the acronym… <nodeInformationFrame>

Where have you looked…item values, Habmin, PaperUI, logs, etc.?

No problem. COMMAND_CLASS_SCENE_ACTIVATION is not listed in <nodeInformationFrame>, it is only listed in <endpoints>.

Yes, all of them, and the exported items in VSCode as well. “Scene Number” is listed as a channel in 2.2, and there is no mention of it in the dev binding in Habmin for example. I also see a different number of channels between 2.2 (14 channels) and dev (15 channels) in Habmin as well.


I think I see the issue. There was an update in the database on March 10, and I’m guessing that was the addition of the scene_number channel because it is not in here. It could have been another update though. @mhilbush or @chris might be able to confirm this. You’ll need to wait for the next binding update to come out and hopefully scene_number will turn up.

Yesterday I updated config params 6 and 8. I changed the min from 1 to 0 as discussed here.

1 Like

Found it… there was an update on March 8 to add SCENE_ACTIVATION, which explains why it is not in the current binding. A view of the history in the database would be handy! :wink:

1 Like

The full history of the published database is on Github, but of course that’s not quite what you’re after, and that’s a bit more difficult unfortunately…

I’m doing some restructuring of the database at the moment - once this is done I’ll publish a new dev binding.

1 Like