OH3.0.0 Chart Sitemap not showing

  • Platform information:
    • Hardware: ARM based
    • OS: Debian GNU/Linux 9 (stretch)
    • Java Runtime Environment: Java 11
    • openHAB version: 3.0.0.
  • Issue of the topic: All seems to be working except I can not get a chart to appear in my sitemap.
    Screenshot 2020-12-29 113826 Screenshot 2020-12-29 114007
  • Please post configurations (if applicable):
    • Sitemap configuration related to the issue
 Group icon="switch" label="Medion Switch" item=MedionSwitch_MedionSwitch {
  Switch icon="switch" item=MedionSwitch_MedionSwitch
                Text item=MedionSwitch_MedionVoltage
                Chart item=MedionSwitch_MedionVoltage label="voltage"
                Text label="Current" item=MedionSwitch_MedionCurrent
                Text label="Power Factor" item=MedionSwitch_MedionFactor
                Text label="Power" item=MedionSwitch_MedionPower
  • If logs where generated please post these here using code fences:
    2020-12-28 19:31:44.176 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item ‘MedionSwitch_MedionSwitch’ changed from OFF to ON
    2020-12-28 19:32:54.505 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item ‘MedionSwitch_MedionFactor’ changed from 0.0 to 0.57
    2020-12-28 19:32:54.542 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item ‘MedionSwitch_MedionPower’ changed from 0.0 W to 4.0 W
    2020-12-28 19:32:54.548 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item ‘MedionSwitch_MedionCurrent’ changed from 0.0 to 0.026
    2020-12-28 19:42:54.522 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item ‘MedionSwitch_MedionVoltage’ changed from 237 to 236
    2020-12-28 19:42:54.531 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item ‘MedionSwitch_MedionCurrent’ changed from 0.026 to 0.027
    2020-12-28 19:47:54.537 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item ‘MedionSwitch_MedionPower’ changed from 4.0 W to 3.0 W
    2020-12-28 19:47:54.545 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item ‘MedionSwitch_MedionFactor’ changed from 0.57 to 0.52
    2020-12-28 19:47:54.549 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item ‘MedionSwitch_MedionVoltage’ changed from 236 to 235
    2020-12-28 19:47:54.555 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item ‘MedionSwitch_MedionCurrent’ changed from 0.027 to 0.026

2020-12-28 19:47:37.586 [ERROR] [components.UIComponentSitemapProvider] - Cannot build sitemap page_f5131ac12b
java.lang.ClassCastException: class java.math.BigDecimal cannot be cast to class java.lang.Integer (java.math.BigDecimal and java.lang.Integer are in module java.base of loader ‘bootstrap’)

That error in openhab.log seems to be the problem.

Any advice for this noob?

Update: I CAN plot voltage in HABpanel from the same Item.

Screenshot 2020-12-29 160646

I now see the chart!

Seems a reboot was required???

Do you have any details how you solved this issue? I am facing exactly same problem, and restart did not help me. Sitemap works correctly till I try to add a chart. After chart removal from sitemap it starts to work again.

Chart definition in SiteMap: (defined via GUI)
Chart item=TemperatureSensorsvetnice_Temperature refresh=10000 period="D" label="Test_Chart"

Item Definition: (defined via GUI)

Error in openhab.log
2020-12-31 13:34:00.666 [ERROR] [omponents.UIComponentSitemapProvider] - Cannot build sitemap SiteMap1
java.lang.ClassCastException: class java.math.BigDecimal cannot be cast to class java.lang.Integer (java.math.BigDecimal and java.lang.Integer are in module java.base of loader ‘bootstrap’)

Platform configuration:

  • Hardware: Raspberry Pi 3B
  • OS: Raspbian 10
  • Java: Zulu11.43+100-CA (build
  • openHAB version: 3.0.0

Charts works well in OpenHAB 3 GUI, just sitemaps are problem.

Or is there any way to show OH3 GUI directly in the Android app, without need of defining SiteMap?
Thank you for any advice.


I am not 100% sure what fixed the problem, but start commenting out lines in the code (with // )until it starts working


//Chart item=TemperatureSensorsvetnice_Temperature refresh=10000 period=“D” label=“Test_Chart”

 I commented out a line. Copied it. and the copy of that line (not commented out) worked. (!!) That does not make sense 
 but it worked.

Hi guys, I’m facing same issue.
I found this migrating from oh 2.3 to 3.0.1, on the sitemap of 2.3 version was working well, but on the new 3 version not. I see something line a broken image on the pc’browser.

I tryed to do the @Rob_Clark suggestions, rebooting also rpi, I tryed also to create many different widget in order to try if there is something wrong with the container, but nothing is fixing it.

Someone has other suggestion please?
Thank You!

1 Like

Hi guys, yesterday evening I found the solution on this post:

so everything was already right, unless fonts.