OH3.0.0.m2 Xiaomi Roborock S50 "configuration error" when adding item

I am trying to get my vacuum controlled through OH, but run into some troubles.
I tried both GUI configuration as well as with things and items files. In both cases same result.
Token and model id are ‘fresh’ retrieved from the cloud.

The Vacuum is on another subnet as OH, but the router is configured to give full access and ping seems to work well.

Any suggestions (e.g. which network port(s) to check) ?
Small side question, below log is added as pre-formatted text. Why do I get a line feed in the 2nd log line, while there is a horizontal scrollbar ?

Skipping periodic update for 'miio:vacuum:s50' UID 'CONFIGURATION_ERROR'. Thing Status
Command added to Queue {"id":14,"method":"miIO.info","params":[]} -> (Device: 
96553344 token: 7A4D7166XXXXXXXXXXXXXXXX6D374150 Queue: 1)
Communication error for Mi device at Receive timed out
No response from device 96553344 at for command 
Sending Ping 96553344 (
Ping 96553344 ( success
Received response for s50 type: MIIO_INFO, result: {}, fullresponse: {"error":"No Response"}
Error received: "No Response"

Silly question, but have you tried turning it off and on again? I mean the robot. I recently got xiaomi vacuum mop pro and it does the same thing - sometimes it stops responding to commands although mobile app and ping works fine. Removing it from dock and turning it off by holding the power button and then turning on always fixes it.

Since it responded to the app and ping I did not switch it off. It is now in a partly disassembled state, because I had to clean it, the cat did something where it shouldn’t :frowning:
Tonight I will try to see if it changed anything.

It’s a pity. The vacuum has been of for one night (actually even battery removed) , but still the same error. I guess I have to dig deeper to find out what’s happening.