OH3 Aeotec Z-Stick Gen5 error - Z-Wave Binding

  • Platform information:
    • RPi 4 8Gb (boot from SD for now)
    • Pi OS Lite (32 bit)
    • Java Runtime Environment: zulu11.43.88-ca-jdk11.0.9-linux_aarch32hf
    • openHAB version: OH3.0.0.M2
  • Z Wave binding and Aeotec Z-Stick Gen5
    Entertaining day trying to set up OH3. The main issue was the an error thrown by the binding saying the stick was offline / error.

The post below saved the day relating to the stick drawing too much power:

I fixed the problem (as per the post) with a really old USB hub in between the stick and the Pi.

However the main topic of this post is the-wave binding. I’ve been installing different versions of Java, OS and RPi4’s all day trying to fix the issue.
Just before I fixed the problem by adding the USB hub, I noted another issue on a complete fresh install.
Web browser cashed data cleared, totally new install, the stick not plugged in yet (on this install), just installed the z-wave binding. Went in to the binding to detect any z-wave devices without the stick ever being plugged in on this build (as a test, I was smelling something fishy).
The binding detected a stick when clearly no stick had ever been connected on this build!

This issue has thrown me all day as I thought OH was detecting the stick but clearly it wasn’t. If the binding had not detected the stick then I would have gone down the ‘dmesg | grep tty’ route sooner which would have pointed closer to the issue.

Is this correct, the binding detects non excitant z-wave sticks?
Can this be changed?

On a plus note, I can now install the OS, Java, OH, Static IP in about 10 mins!



Can you describe what this means? As far as I recall, the binding doesn’t auto detect dongles at all.

This may explain the confusion. I assumed (probably wrongly) that the binding did detect sticks, because in OH2 adding a stick is not normally shown on the binding search page as its hidden behind ‘Add Manually’ button and i probably went on the ‘add manually’ page 2 years ago. On OH3 the ‘Add Manually’ list is on the front search page of the Z-Wave binding so its jumps out. So moving from OH2 to OH3 and not used to seeing the stick on the front search page, plus the page loads a bit slow it made me think it was detecting the stick!

Hi, I have the same problem during new OH3 set up. I added the zwave binding and based on the binding I added “Z-Wave Serial Controller”. In the setup of this thing the serial port detected “/dev/ttyAMA0/”.
Based on this post, I find out that the port is detected indedant if Aeotec Stick is plugged in or not. After adding the thing openhab is rebooting every 2 minutes. Openhab.lg ends with:

[INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null

I will try with an active usb hub like described here: https://community.openhab.org/t/solved-oh3-zwave-binding-z-wave-serial-controller-aeotec-z-stick-gen5-remains-offline/108182/35

Hi Barnecke,
Is this on a Pi 4?
If so the Z-Stick, apparently draws a lot of current it also struggles with USB3. If your booting off an external HDD without its own power the Pi will do assorts of random stuff including reboot due to excess power consumption over the Pi4’s USB ports.

My solution:
As the Pi 4 supports USB3 and the Stick is USB2. I’ve put the Stick into an old USB1 hub and the hub into the Pi (This hub can also be powered). This fixed the Stick not connecting to OH3.

The current draw over USB issue was fixed by a powered USB3 hub for the HDD and put the USB3 hub into another port on the Pi.

Just to highlight the current draw of the Z-Stick. it wont run on my laptop standard USB ports, it has to be in the high powered USB charging port before it will run and be recognised via Zensys.

Its now stable as a rock.



Hi John,
thx, yes it is a RPI4 with an USB SSD Stick, which runs until now very fine.

I ordered a powered USB3 Hub. Will arrive tomorrow. I hope it will fix the problem.


I found something more. in openhabian-config in “systems settings” - “35 serial ports” serial console has to be deactivated for e.g. zwave.
After activating both options and restart, oh3 will start the Zwave controller, but it stays offline.

2020-12-28 22:59:10.018 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller

2020-12-28 22:59:10.023 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.

But status still “offline”

That sounds like the Stick USB3 fault. Is the Stick in a USB2 hub and the hub into the Pi?
Incidentally, the Stick works fine on a Pi3 as that’s USB2.

I tried both (usb2 and usb3) on my pi4, but not working.
Today my active USB hub (https://smile.amazon.de/dp/B07P6MPXJ7/ref=cm_sw_em_r_mt_dp_ajp7FbHEKV3DJ?_encoding=UTF8&psc=1) arrived and AEOTEC Stick is emediatly found.
It is listed with “lsusb - t” also.
Hardware seams to be incompatible with PI4, becasue my other z-wave stick (ZMEEUZB1) is found by PI4.