OH3 and Hyperion.NG not running due to auth error


is there a list available which bindings are supported/tested with OH3?
I migrated from OH2 to OH3, but my hyperion plugin is not working properly.

I am able to setup a thing and link it to my hyperion server. It is shown online.
I am able to create an equipment with points out of the thing-channels and I am able to add those to my model.

BUT: If I want to control the server via the buttons nothing happens (but it was running with OH2).

Any ideas why? Or how to debug it? OH log (openhab-cli showlogs) does not show anything helpful.

Thanks for any help or hints

See Add-ons | openHAB and at the top left of your screen select “Version: latest” (latest is OH3.0)

Sorry however, but I can’t help with your Hyperion questions.

Thanks for the hint, seems as if I was blind in the docu :wink: But the good thing is that hyperion.ng should be officially supported.

Anyone else who can help me on my hyperion issue?

No one using hyperion with OH3?
Or am I the onlyone have problems to get it running?

You didn’t tell anything let alone details such as logs about your problem so don’t expect anyone to answer

How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

1 Like

I am running hyperion ng on OH3, but as Markus wrote, there is not enough information to help you. Let me know if you have further questions.

1 Like

Valid point, sorry for the low amount of information, this is because I do not know where to start from.
Hyperion itself is running and I am able to control the lights e.g. by the web interface of hyperion.

The log of hyperion is not showing any request from the direction of openhab.
Unfortunatelly I am not able to find any logs on OH3, can you help me where to look for more details?

Well, what I did was easy:

  • installed the binding
  • created a thing (you can choose between a normal hyperion server and a NG one). I think I had to manually enter information like ip address etc.

After that I had a working hyperion thing and I could e.g. change the brightness, I should mention that I have both openhab and hyperion running in docker containers on the same host, but that shouldn’t be needed. Just to check, can you ping your hyperion server from your openhab machine? What is our setup like? You say you cannot find logs on openhab. What do you mean by that? Inportant information should be in openhab.log. What does that say regarding hyperion?

Thanks for your feedback, I am running my hyperion.ng on a RPI4 and my openhab on a RPI3 in the same network. Both are able to talk to each other.

On my RPI3 OH3 runs as a service and I did some more investigations now on how to log/debug with OH3. I do use openhab-cli console and set the log level for hyperion to DEBUG, with this I do get the following

21:51:59.054 [DEBUG] [internal.connection.JsonTcpConnection] - Sending: {"command":"serverinfo"}
21:51:59.064 [DEBUG] [internal.connection.JsonTcpConnection] - Received: {"command":"serverinfo","error":"No Authorization","success":false,"tan":0}
21:51:59.070 [DEBUG] [on.internal.handler.HyperionNgHandler] - Server rejected the command: {"command":"serverinfo"} - Reason: No Authorization

Where would I need to configure an authorization which is claimed in the log?

Good question. I must admit that I did not touch anything regarding passwords on my hyperion installation. Did you do so?

If I look at my hyperion thing, I cannot enter a password or something similar.

What do your hyperion logs say? Increase the log level there too. What are your settings under Network Services? For example did you turn on Local API Authentication? (mine isn’t)

Debug level for hyperion is already “DEBUG”
The only thing I get is:

2021-05-12T20:16:46.434Z [hyperiond JSONCLIENTCONNECTION] (DEBUG) (JsonAPI.cpp:81:handleInstanceSwitch()) Client '::ffff:' switch to Hyperion instance 0

The IP 150 is my RPI3 where OH3 is running on

Networksettings of hyperion are all set to no authentication, only the admin password is active at the moment

That is not an answer to my question. What are your settings? Mine are

One more question, what is your hyperion NG version as it is still in development

Sorry, I though I answered it, as only the admin password is active:

But seeing your screenshot I also tried to activate API Authentication… and guess what… now it works, but I don’t get why :roll_eyes:

If it works don’t fix it. Ours in not to reason why…

Perhaps good idea to change the title of this post to something more informative to help a future user.

1 Like

Another issue I observed now, I wanted to use the channel “clear priority”
Are you making use of this channel?

If I I set this to e.g. ALL able to set any color any longer, but a can also not clear the priority channel and set it back to null.

Did you have similar observations?

I don’t use that channel, so I can’t help you there. I suppose you could try playing with the web interface to see what happens if you set stuff on openhab.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.