OH3 and Zwave - Update from device

Hi All,
I have make a new configuration for my home in openhab3.
I have discovery all my zwave device and I have make only one simple sitemap.
If I manage the device from system (sitemap) all works fine (I can turn on/off the light).
If I change state from inputwall, the sitamap (and administrative page) doesn’t change status.
In events.log the status change correctly.
Do you can help me to refresh status?

I have some update.
In dual switch, I had link switch1 and switch2.
On Fibaro FGS222 I have moved switch1 to generic switch and now works fine.

I have copied the configuration on Aeotec ZW132. If I move switch on inputwall, I receive the update on Openhab. If I move switch2, openhab update always switch.

On events.log I have the right on/off.

Any suggestion?

Do the logs show the device sending a status update? If not then device polling can be enabled or you can contact the vendor to request that feature.

For sending a update, I need to enable the first channel.
For fibaro, after this enable, it report the status of all channel.
For Aeotec, this function doesn’t works. I analyze the settings of device.

I did not study the manual, bit check Parameter 6.

I have view this and there isn’t Parameter 6.

I have check on my old configuration on OH2 and I had configured only S1 and S2 (not generic switch).

From our database entry for the FGS222 here.

The fibaro now works…The problem is on Aeotec ZW132

What firmware version? We have 2 entries. Perhaps posting the xml file generated by OH could help.

Do you mean this property?

zwave_class_basic                    BASIC_TYPE_ROUTING_SLAVE
zwave_class_generic                  GENERIC_TYPE_SWITCH_BINARY
zwave_frequent                       false
modelId                              ZW132
zwave_version                        2.2
zwave_listening                      true
zwave_plus_devicetype                NODE_TYPE_ZWAVEPLUS_NODE
manufacturerId                       0086
manufacturerRef                      0003:0084,0103:0084,0203:0084
dbReference                          1017
versionMin                           2.0
zwave_deviceid                       132
zwave_nodeid                         5
vendor                               AEON Labs
defaultAssociations                  1
zwave_routing                        true
zwave_plus_roletype                  ROLE_TYPE_SLAVE_ALWAYS_ON
zwave_beaming                        true
zwave_secure                         false
zwave_class_specific                 SPECIFIC_TYPE_POWER_SWITCH_BINARY
zwave_manufacturer                   134
zwave_devicetype                     3

That was not what I meant but it told me what I needed. Here is the database entry for your device.along with a copy of the manual.

Try changing configuration parameter 80 for Group 1 Notifications. The controller is associated with Group 1.

You do not state what version of openHAB. It needs to be 2.5.7 or later.

EDIT: I see an issue I need to fix for this device. The snapshot binding after the next database export should have the fixes.

I have canged parameter 80 from 3 to 1 and now S1 was reported correctly, but not S2.

Now I use openHAB 3.0.0, in openHAB 2.5.11 it works fine.

Option 3 is supposed to work when switching manually, I think.


If you need I can collaborate to check and resolve this issue.

I have to syncronize the zwave network and now I have parameter 80 to 3 but S1 report change and S2 no…

It might be worth checking with the manufacturer support to see if that is expected behaviour.

Yes but on OpenHab 2.5.x works fine…
Why doesn’t works on OpenHab3?

There should not be much change as far as I am aware.

@chris may want some unfiltered DEBUG logs to troubleshoot further. The binding documentation says how to set that up.

I have had problems with this module in the past…

I’m ready to help for solve the problem also in this version…

1 Like