OH3: Broadlink Binding Creation Conflict

Hello guys.
I just moved to OH3 and installed the Broadlink binding.

I tried to search my broadlink device and I did found.
But when I try to add my device as thing its pop up an error: “Error during thing creation: conflict”.
(Adding a photo)

Where did you get the binding from ?
I can’t find it - just was interested if it is possible to identify the root cause by checking the source code.

I just easly searched the binding list ‘Broadlink’ anf found that immediately.
It is found the right thing but I just get this message and tried to search everywhere with no success.

Basically I just want to add my broadlink device.

It’s an unofficial binding that hasn’t been updated in just under a year. It’s buried in this post if you want to take a look at it.

@themillhousegroup hasn’t been seen here since last September, but I found their website/blog while looking at GitHub and in January/February they mentioned some frustration trying to get the Broadlink binding merged into the openHAB distribution.

Your screenshot seems to show Broadlink RM Mini.
The binding that I see in the list of bindings is the Broadlink Thermostat binding.
Do you use that one ?

I don’t think this is specific to the Broadlink binding. If you search for “Error during thing creation: conflict”, you’ll find that it’s shown up with other cases.

https://community.openhab.org/search?q=Error%20during%20thing%20creation:%20conflict

What other bindings do you have installed?

Yes

Mm… so it might cause from other thing?
Here is an answer I saw:

So if I get it right
*The error conflict can be from other things not just the broadlink binding.

  • I am using Broadlink thermostat Binding .

I still not sure what the main reason for this. Some say in those discussion that its a bug.
So I tried:
To delete all my things and bindings.
Reinstalling Broadlink binding.
And still no news.

The Broadlink Thermostat binding can not control an RM Mini. The unofficial binding I linked to earlier can, but you have to manually install it by downloading the file.

Sorry, I assumed that you were using the unofficial binding due to your blacked-out screenshot, but I realize now that you tried to add it as a thermostat.

image

It’s good to be careful about what you post in images, but this made it difficult to get any context.

So, remove the Broadlink Thermostat binding, then manually add the unofficial binding.