OH3 - BTicinosmarther Addon not working - API Gateway error

I am trying to control 2 Chronothermostats using OpenHAB3 and the bticinosmarther addon. I can create Bticino Bridge and discover automatically one of the 2 chronothermostats, but I cannot connect to none of them. I get an error:

2021-05-12 19:35:05.272 [WARN ] [ternal.handler.SmartherModuleHandler] - Module[bticinosmarther:module:BT_App2:1940af83c8] API Gateway error during polling: Gateway Offline

I have subscripted to Smarther API and created the application. I have followed exactly the steps provided in the addon documentation (see bticinosmarther ). I am not sure if this issue is related with OpenHAB or with Smarther or with the binding.

I have tried using the Smarther v2 API via Legrand’s site and it works just fine.

Any feedback would be really helpful.

Hi @gntouts, I had the same issue.
The Bridge was tested with only one thermostat, when it tries to discover the thermostats it creates an association using only the first 8 characters of the module id, if your thermostats have sub-sequential id, like mine, it won’ work.
To solve that you should enable OH logging to debug, then discover the thermostats again and you’ll see the two ID. Once you have the second ID, simply add the thermostat manually.
I already reported that issue.
Hope this helps.