[OH3] CC2531 + Zigbee Binding + Osram Smart+ OR Blitzwolf BW-SHP13 - Error "Node has not completed discovery"


  • Platform information:
    • Hardware: RPI4, 2GB
    • OS: Openhabian 3.0.1 Release
    • Java Runtime Environment: openjdk version “11.0.10” 2021-01-19 LTS
      OpenJDK Runtime Environment Zulu11.45+27-CA (build 11.0.10+9-LTS)
      OpenJDK Client VM Zulu11.45+27-CA (build 11.0.10+9-LTS, mixed mode)
    • openHAB version: 3.0.1 - Release Build

Actual results:
The Device appears OFFLINE. It’s not responsive and it’s not sending expected data. I tried multiple of these plugs, none are working beside discovery but offline/no channels afterwards.
The setup works well with Lidl Zigbee bulbs and Aquara Temp&Humindity sensor (full discovery and functionality).

Expected Results:
The Device appears ONLINE. Can be linked to Item and sends the expected data.

Repro Steps:

  • From things menu on localhost:8080 start a new discovery
  • Select Zigbee binding
  • Select Scan
  • Reset the device by pressing the button for 5 s - the light flashes 3 times
  • Observe discovery new hit of “Unknown ZigBee Device xxxxxxxx”
  • Add as a Thing
  • Observe Device status: OFFLINE - Node has not completed discovery

Things I tried:

  • Disabling and Enabling the Device
  • Restarting the Device
  • Removing the Device and discover it again

I wonder if anybody has one of these device successfully working with OpenHAB Zigbee binding? They seem to be supported by zigbee2mqtt.
If necessary I can also provide logs.
Thanks a lot for any hints!

Hello Chris,

i have encountered the same issue.

See my post in the forum three days ago:

thanks for the information. Interestingly my “old” Zigbee Devices (Lidl Light Bulb, Aquara Sensor) still work fine -> but have been paired with 3.0.1.
So I was believing that the OSRAM smart+ plugs are not supported - but they have been working for you in 3.0.x version already?

Yes they did. Look at my forum post.