[OH3.1.0 M1] Zigbee Device not recognized - Worked with 3.0.1


same behavior with two systems (Raspi 4, PC) OH 3.1.0 M1 and a Zigbee cc2531 stick with firmware Koenkk 20201127.hex .

Whenever i try to pair a device, the device is found and bound but not recognized. So it stays “unknown device …”

With OH 3.0.0 and OH 3.0.1 everything works fine and the device is recognized. Tried with Ikea Bulb and Osram Smart+.

I am pretty new to openhab.

I have attached the log file here:
log.txt (22.4 KB)

It’s hard to tell from this log what is happening. The log simply shows a device leaving the network. I could guess that the device is a ZB3 device, and your stick might not support the new requirements, but if you’ve had this working previously, it probably isn’t that.

There is no difference between 3.0 and 3.1 so it will not be a binding issue.

Hi Chris,
thanks for your reply. Maybe i posted the wrong part of the log.
The device was an Osram Smart+ Plug. This is definitely not a ZB3.
I have Openhab 3.1.0M running on my PI. In parallel i have an installation on my PC. OH 3.0.0 was installed, device was recognized as Smart+ worked. Upgraded to OH 3.0.1 device was recognized. Upgraded to 3.1.0 device was not recognized -> unknown device.

Ok, I’m not sure what I can add. There was no change in the binding so it’s not likely to be related to the binding and without a log it’s extremely difficult to comment - sorry.

Hello Chris,

i have added a new log. I covers the time from putting the plug into binding mode and finish the discovery through the binding.
log.txt (59.8 KB)

What is interesting is that when i add the “unknown zigbee” Thing and delete it later i here the Smart+ plug clickering, so it is really removed.

regards Christoph

I tried now deinstalling Zigbee binding, installing again, changing baud rate etc. Upgraded to M02 release.
It does not work - plugs are found but can´t be setup propoerly (no channels visible).
Unfortunately no further help, even other people seem to share the problem :frowning:

I will now go Zigbee2MQTT binding way - it is somehow a pitty but :frowning:

On the same Raspi4, SW stack just latest Zigbee2MQTT installed - works like a charm - the plug is found out of the box, energy measurment also ok - great.
Why is OpenHABs Zigbee finding a bit picky?

It’s really hard to know what you’re doing here. You don’t mention what the device is that you’re having issues with, or what the coordinator is that you’re using.

Changing baud rate will likely not help. If you’re using an Ember dongle, then it will likely use either 57k6 or 115k2. The lower rate will work with software flow control and the higher rate with hardware flow control - if you get it wrong, the dongle (coordinator) will simply be offline and nothing will work,.

Hello Chris,
at the start of the thread i do give the needed information “Zigbee cc2531 stick with firmware Koenkk 20201127.hex”. Of course i use the c2531 coordinator.

I do again state that with 3.1.0M1 the device is not recognized any longer. So stick and coordinator are fine.

I have to use 3.1.0M1 because my Fritzbox binding lost connection with lower Releases.

Regards Christoph

Sorry - I was responding via email to @hab_pi who has provided no information at all.

Hi Chris,
Sorry, I have seen you email just right now - my fault :frowning:

I use the same cc2531 but with older SW from Koenk 08.06.2019 - it is the default SW as bought from here:

@Chris, I agree, baud rate has not changed anything - tried all combinations