OH3 choose binding page not loading

Platform information:
RPi 4 8Gb (boot from USB HDD)
Pi OS Lite (32 bit)
Java Runtime Environment: zulu11.43.88-ca-jdk11.0.9-linux_aarch32hf
openHAB version: OH3.0.0.M2
Z Wave binding and Aeotec Z-Stick Gen5
Browser: Chrome and Edge

Z-Wave binding installed

Just trying to add a Z-Wave ‘Thing’. After clicking on Things then Add I get this and nothing else:

The back button works.
Tried a reboot and no change.
Any help debugging would be great.

Try the latest snapshot.There have been many changes since M2.

Thanks Bruce.
The full OS reinstalled and the latest snapshot (openHAB 3.0.0 Build #2024). Its now working.
That said milestone 2 was also working until today. I suppose time will tell.

1 Like

I have tried playing around with OH3 Milestone 3 a few days ago and I’m hitting the same problem. The Things subpage is stuck in “Loading …”. I can click on inbox and see all the things that are listed there, but I’m unable to see my currently configured things. All I have is in things-files, etc. I have started with a clean userdata folder.

Any idea how to troubleshoot?

Try a different browser or clearing the browser cache. Chrome is bad about retaining cached data instead of loading new data.

I have tried on Windows with Edge Chromium and on Mac with Safari. Both show the same behaviour.

1 Like

I also tried clearing the cache on chrome with no joy, hence trying Edge.
Edge hadn’t run openhab before so it shouldn’t have an issue relating to cache. Within Edge the same page reacted exactly the same as in chrome from the very start. This lead me to openhab as the culprit.

openHAB 3.0.0 Build #2024 seems to be stable on the page load front for the moment.

I’m running openHAB 3.0.0.M3 (docker alpine build)

I have just looked into Developer Mode in Edge Chromium and this is the error I’m getting:

Uncaught (in promise) TypeError: Cannot read property ‘localeCompare’ of undefined
at app.js:22
at Array.sort ()
at app.js:22

Don’t know if this helps anybody.

It works fine in Chrome on Windows.

I have just installed Chrome on Windows and the error message and the behaviour is the same.

app.js:22 Uncaught (in promise) TypeError: Cannot read property ‘localeCompare’ of undefined
at app.js:22
at Array.sort ()
at app.js:22

There is something else wrong. LocaleCompare points to something regarding language options or stuff like this. My system is a mixture of english and german language variants. Maybe this has something to do with it. My display language is english, but my regional settings are german.

I’m on Windows 10 Pro 64 bit. Language is set to English UK for my browsers, machine OS and OH3.

The OH page was working fine for a few days, Then with OH up for maybe 3 days, I booted my windows machine, jumped on chrome, went to the page and it did not load. no changes to any of my setup as far as I can see between running and fail.
The only fix I could find was the suggestion by Bruce to use the latest snapshot. Wiping OH and the OS on the Pi and starting from new. Its been running ever since without issue.

I’m now running Snapshot 2025 since this is the newest I could find on docker hub. While openhab was starting I could shortly see one thing that I have been creating using the UI. Loading of my things-files wasn’t yet finished. As soon as my things were loaded, the problem reappeared. So there seems to be something with the things that I have configured, that screws up the UI. I have checked the regional settings idea by installing a Win10 box with all US settings and the problem was still there, so the regional settings idea is not valid. I will go through my things and see if I can find one with maybe some weird german characters or stuff like that.

I narrowed it down to my homematic.things file. this holds quite a few homematic things which are working perfectly but somehow seem to break the things UI. I will see if it is a specific thing in it or just the amount of things. Thanks for your help, I will try to narrow it down without spamming the forum any more :wink:

1 Like

On Chrome open the things page, hit F12 and go to the console tab in the panel that opens, then do a full refresh Ctrl+F5 and watch for errors.

Found it. I had two things that had the same “identifier”. I have commented one of them out and it is now working. Thanks for your help.

1 Like

Milestone 3 is newer. I am running it in Docker.

There is still something wrong here. Every once in a while this problem reappears and the page is stuck at “loading…:” the error message is the same.

I have to move some things files out of the scope of openhab to fix the error. After this I can move the things files back to make everything work again. After a few minutes or maybe after a few things I do in the UI the problem reappears. I will work around this with typing the name of the things in the URL, but maybe somebody wants to debug this with me. Should I open an issue for this?