[OH3] frontail no output

I have reinstalled openhab3 tonight, so far everything works, only in the frontail I get no output displayed.

I have already restarted the server and reinstalled via openhabian-config frontail. All these actions have no effect.

When I open the Chrome-DevTools, I get the following message:

index.js:83 WebSocket connection to 'ws://192.168.0.51:9001/socket.io/?EIO=3&transport=websocket' failed: Error during WebSocket handshake: Unexpected response code: 400

Can someone please help me with the problem ?

I just can confirm that I have the same problem.

I installed openhabian 1.6.2.b freshly and frontail remains empty.

I’ve tried to start frontail manually on different logs and the same applies. It is not able to show any log information.

I’ve reinstalled frontail via openhabian-config and even manually from GitHub and it still doesn’t show any logs.

Lost for ideas here and would really appreciate a solution.

Please to a:

sudo systemctl restart frontail

What does then

sudo systemctl status frontail

show?

Frontail is running and the Webserver is accessible on port 9001. However, it does not show any logs.

[09:46:58] openhabian@openHABianDevice:~$ sudo systemctl status frontail
● frontail.service - Frontail openHAB instance, reachable at http://openHABianDevice:9001
   Loaded: loaded (/etc/systemd/system/frontail.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2021-01-06 09:46:58 CET; 11s ago
     Docs: https://github.com/mthenw/frontail
 Main PID: 14210 (node)
    Tasks: 12 (limit: 4915)
   CGroup: /system.slice/frontail.service
           ├─14210 node /usr/lib/node_modules/frontail/bin/frontail --ui-highlight --ui-highlight-preset /usr/lib/node_modules/frontail/preset/openhab.json -t openhab -l 2000 -n 200 /var/log/openhab/openhab.log /var/log/openhab/events.log
           └─14225 tail -n 200 -F /var/log/openhab/openhab.log /var/log/openhab/events.log

Jan 06 09:46:58 openHABianDevice systemd[1]: Started Frontail openHAB instance, reachable at http://openHABianDevice:9001.

Even starting frontail manually on different logs, has the same effect.

[09:47:10] openhabian@openHABianDevice:~$ sudo systemctl stop frontail
[09:48:51] openhabian@openHABianDevice:~$ sudo /usr/lib/node_modules/frontail/bin/frontail /var/log/syslog

Ok. That’s good.
Just to check a bit further:
in case you do

sudo tail  /var/log/openhab/openhab.log

you get some output ?

Yes, that works fine. Currently my only way to see the logs. There is a lot happening in my openhab installation, so there should something to see in frontail :wink:

i tried to debug the whole thing until 2:00 this morning, but unfortunately was not.

Had then in the output of the frontail that he reads the info from the log files, but he does not give them to the client.

Tried it with and without ZRAM and it didn’t change.

I am encountering the same problem. Unfortunately, I do not have a solution, either. Log-Files are filled properly and Frontail is running. I am getting the same error on the frontend (i.e. in the browser) that is described in the first post. It seems to me that the browser interface is not able to fetch the log files from the backend as the websocket request is denied with error code 400. Looks like there is a misconfiguration of the communication between frontend and backend.

Hi there

I did a fresh install of openhabian today to practice a little on the auto backup process and have encountered the same thing, no front tail activity.

I did the restart & status of front tail.
There is output if I do, sudo tail /var/log/openhab/openhab.log

I thought it was something I did, so I started a second time with openhabian 1.6.2.b with the same outcome. Interestingly the front tail in the new openhabian I set up last week for migration works fine with output.

Regards,
George

I can confirm George’s observation.

I’ve installed openhabian 1.6.2b on Monday and have Frontail running and working.

Yesterday, I’ve reinstalled openhabian 1.6.2b several times (on a different SSD) and Frontail isn’t working anymore.

I have already opened an issue about this since yesterday.

1 Like

I checked for ( linux ) system updates and openhabian-config ( openhab3 branch ) updates and installed both and also reinstalled frontail.
Here it is running so far.
Only during a reboot of the machine that hosts openhab I see the socket error message. Once it is up and frontail service is running again the messages are being displayed again.

1 Like

I did some further research and debugging and I found a workaround that works for me at least.
The received error message used to be a common and known bug in Frontail. This especially holds for setups using NGINX if I understood correctly. See Fix websocket error during handshake (#195) · mthenw/frontail@0aad9dd · GitHub. As the comment on the commit suggests this might have broken other setups, which we are encountering right now.
Funny thing is that this version is quite old already (Feb 19th, 2020) and it is already used in my openhabian installation using OH 2.5, which works just fine. Hence, there seems to be some kind of incompatability with the current openhabian release.
Reverting above change did the trick for me for my OH 3.0 openhabian installation.

  • This is the procedure that worked for me:
  • Go to your frontail installation and there into the web directory (/usr/lib/node_modules/frontail/web - for openhabian default installation)
  • Edit the index.html
  • Quite at the end there is a javascript block including the following lines
 	var socket = new io.connect('/__NAMESPACE__', {
 		path: '__PATH__/socket.io',
 		transports: ['websocket']
 	});
  • Change this part to (i.e. remove the second parameter, do not forget about the comma)
 	var socket = new io.connect('/__NAMESPACE__', {
 		path: '__PATH__/socket.io'
 	});
  • Restart the Frontail service

After I did that Frontail worked again for me.

I am not sure whether this “fix” could or even should be integrated into the openhabian release since it also seems to be working for some people. Maybe one of the people for whom frontail is working from scratch could try if this change breaks it in their environment. Nevertheless, I would be interested if this works for the other affected users.

2 Likes

thanks for debugging. I have installed the fix and now it works again.

I did a fresh install with version 1.6.2 and everything is working fine.
So ist this bug only occurring with 1.6.2b ?

the problems that are described in posts that I saw were solved when extra entries in the NGINX setup were added. Have you also tried that ?

I have seen that as well. But I do not use NGINX at all and that is possibly the reason why the problem occured in the first place.

Just did a fresh install with 1.6.2, so the issue seems to occur not only with 1.6.2b. I’m not using nginx, too with my fresh install, so obviously something else has changed between 2.5 and 3.0.

Thanks @mischateeh, removing the line worked! At least a good workaround, but a fix from Openhab side is not possible here.

Hi there,

The fix worked for me on a fresh install. Thanks for debugging!

Cheers,

I did a check and it is indeed a problem of socket.io 2.4.0 while it is not a problem with socket.io 2.3.0: