OH3 in Docker with Sonos binding

Hello,

I have read various contributions to the error message COMMUNICATION_ERROR The UPnP speaker RINCON_xxxxxxxx is not registered “. I could not find a solution, however. An account has been set up with Sonos and the player Play: 1 is registered. I was able to access the UDN at” http: / / ip-your-players: 1400 / status ". Port 1900 is also released, restart attempted, but the thing with the above message is always offline.

I ask the users again: have there been any new findings in the meantime?

Did you read the binding documentation?

Running in a docker container most likely is the same as a different network.

I previously had some reliability issues with my sonos and my dockerized OH. These, however, were the same as all the other upnp issues that have been recently fixed, not a problem with docker. As long as your container is set to network “host” there’s no issue communicating with the speakers. As for improving the reliability, see the follow post:

I have had no sonos connection drops since modifying the the settings as per that post.

Thank you for your answers. I set up the Openhab container using a Docker Compose file. The “network_mode: default” instruction has specified the “Bridge” mode. How is a change made? Can I now delete the container and set it up again with network_mode: Host? What else do I have to consider besides a backup? I have not yet made such corrections.

@JustinG

Did you also make the changes in the services / runtime.cfg file?

If you have followed the other setup directions then your data is either in a persistent docker volume or external folders on the device running docker. In that case, yes, you should be able to just create a new container with the new network mode and it will use the same image and find the same data volumes.

That said, a backup is never a bad idea when trying something new.

Yes I did. I use the following settings for a sonos system that has 5 play1’s and a play3.

org.jupnp:threadPoolSize=25
org.jupnp:asyncThreadPoolSize=25
org.jupnp:retryAfterSeconds=300
org.jupnp:retryIterations=8
org.jupnp:timeoutSeconds=15

Great, that’s a very good help. But I won’t be able to make the changes until tomorrow. Then I’ll get in touch with you again.

Now, however, I am facing a greater challenge. This is my current docker-compose.yml:

version: '2.2'

services:
  openhab3:
    image: "openhab/openhab:3.1.0"
    container_name: openhab3
    restart: always
    network_mode: default

    volumes:
      - "/volume1/docker/localtime:/etc/localtime:ro"
      - "/etc/TZ:/etc/timezone:ro"
      - "/volume1/docker/openhab/addons:/openhab/addons"
      - "/volume1/docker/openhab/conf:/openhab/conf"
      - "/volume1/docker/openhab/userdata:/openhab/userdata"
      - "/volume1/docker/openhab/photos:/openhab/photos"
    environment:
      OPENHAB_HTTP_PORT: "8060"
      OPENHAB_HTTPS_PORT: "8463"
      EXTRA_JAVA_OPTS: "-Duser.timezone=Europe/Berlin"
      USER_ID: "9001"
      GROUP_ID: "9001"
      LC_ALL: "de_DE.UTF-8"
      LANG: "de_DE.UTF-8"
      LANGUAGE: "de_DE.UTF-8"

The change of the network mode brings an error message “docker.errors.InvalidArgument:” host "network_mode is incompatible with port_bindings
-sh: docker.errors.InvalidArgument :: command not found ". What else needs to be changed?

May I ask for support again?

I have now changed the docker-compose as above. This is probably a kind of minimal configuration. Maybe she still have suggestions for improvement. It works like this at the moment, the Sonos binding is now online! But I still have to configure the services / runtime.cfg file and then contact me again later.