OH3 / Innogy: Variable actuators 'gone'

I just noticed that all my virtual actuators that I created in the Innogy app and which were (are) represented in OH3 as variable switch now have the status ‘gone’. All other things from the Innogy binding are still online.
The thing status shows:

OFFLINE
GONE
Device not found in innogy config. Was it removed?

When using the Main-UI to pause disable/enable the thing my log-file shows the following:

2021-03-07 20:47:22.198 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'innogysmarthome:VariableActuator:SMARTHOME02:3fa5617651c1465f8873d078b024214a' changed from UNINITIALIZED (DISABLED) to INITIALIZING

==> /var/log/openhab/openhab.log <==

2021-03-07 20:47:22.210 [WARN ] [internal.handler.InnogyDeviceHandler] - initializeProperties: The device with id 3fa5617651c1465f8873d078b024214a isn't found

==> /var/log/openhab/events.log <==

2021-03-07 20:47:22.214 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'innogysmarthome:VariableActuator:SMARTHOME02:3fa5617651c1465f8873d078b024214a' changed from INITIALIZING to OFFLINE (GONE): Device not found in innogy config. Was it removed?

Anybody else with the same issue.
I’m running OH 3.1.0.M2

Update 2021-03-10:
I also have my old OH2 system running on RPi (to compare rules, layouts etc) and in OH2 the actuators are online.

Update 2021-04-06:
In the mean time I’ve upgraded to OH 3.1.0.M3 but still the same issue.

I’ve removed the thing and try to re-discover: nothing.
I’ve manually added the thing (taken the ID the same as when you use the Innogy web-UI and click on the specific status, it’s shown in the URL).

Same problem over here - but only since the recent upgrade to OH3.1. With 3.0, the variable actuators worked fine. Does anyone have an idea on how to fix this?

Sorry to disappoint you, but I didn’t find a solution yet.

My workaround was: going back to release 3.0.2 and reboot the smart home central. Then the variables were back in OH

1 Like

Are you still on that version? Or did you find an other solution or work-around?

No, I am still with this “solution” - my next attempt will be a clean reinstall of OH3.1 to avoid any issues which were caused by my long migration history (from 2.2 onwards). Do you have any new hints which I should take into account?

Nope, it’s still on my to-do list.
I’m thinking of setting up a new test system with a new sd card (RPi) to debug this issue.

Hi,
I’m having the same issue, fresh install OH3.2M4, variable actuators were not found in the scan. I added one manually.
Thing shows as “Gone” with the text:
Device not found in innogy config. Was it removed?

Hi @derkens was the manual installation successfu

Yes, I just added it using the id from my current 2.5 installation.
However it is not working, also tried a second variable actuator, same result.
Scan found every device, except the variables.

edit 2-12:

Just noticed there is also logentry when restarting the binding:

2021-12-02 05:26:30.455 [WARN ] [internal.handler.InnogyDeviceHandler] - initializeProperties: The device with id e2a2a51fxx11476b95d867
4d744b9b17 isn't found

Just crosschecked with a fresh clean OH3.2 install, but still the same bug: when scanning the inbox, variable actuators are not found, when adding them manually, they show status “gone”. Any idea on how to fix this?

I’m don’t know how to fix it, I have made an issue on github here:
https://github.com/openhab/openhab-addons/issues/11741
but not much response / action …

For now I still have my 2.5 install active and I import the items with the remote server binding.

Just to let you know, @Novanic fixed it.
You can wait for the next update of openhab, or you can download the binding from the link in the github issue linked in the post above and install it manually.
I did just that and I have the variable actuators back.

1 Like