OH3 Main UI: YAML code edit does not trigger "Pending" ZWave messages and doubled ZWave parameter

@chris I just tested the new main UI on my ZWave devices. The first thing I noticed that the parameter 2 on my FGSD002 smoke detector appears twice in the list:

Is this an error in the ZWave database or in the main ui? Sadly I cannot access your ZWave device list anymore.

I also tried if a change to the thing’s yaml code also triggers a configuration message to the ZWave device, but editing the YAML does not trigger the “Pending” state on the parameters. Should this work or is this way not supported to send configuration parameters to the ZWave device? This would be handy for me because my smoke detectors often loose the connection and I have to re-add them and set all parameters again.


I updated the database to remove the duplicate parameter.

Regarding the “yaml code” - I’m afraid that I don’t know what this does so can’t really comment. I guess this is nothing to do with the binding so probably it’s a question for the UI?

1 Like

Too fast for me :slight_smile:

1 Like


I assume that this has been there a long time - it was in both versions of the device, so probably has been there since the beginning and no-one noticed :slight_smile:

I tracked it back to June 2018, there have always been duplicate entries :rofl:

1 Like

Just double checking: you clicked ‘Save’ after editing the YAML?

Yes, I’ve just tried several ways:

  1. If I edit the YAML, save and return to the “Thing” view the parameter is not updated.
  2. If I edit the YAML, return to the “Thing” view the parameter is updated, but after I click on the “Save” button the Pending label does not appear.
  3. Also sometimes the “Pending” label does appear, but disappears again when I refresh the page.