OH3 MainUI on smart TV's

Did anbody tried out the mainUI on a smartTV browser (fe LG)?

I’m getting the page, and I can work with the overview page.
But when I open the locations, these stay empty? The same for the other tabs.
On a PC or smartphone, this is working fine…

EDIT: which OH version are you running?

1 Like

I’m running 3.0.1.

I can provide a test build with a fix if you want to try it out, but you’ll need 3.1 …

I can always install a new server beside to test it out. Will not be for today, but certainly later on this week…

I prepared a bundle with latest codebase + (potential) fix.

Please run the following command from OH console (need OH 3.1):

bundle:update org.openhab.ui https://github.com/crnjan/openhab-webui/raw/feature/echarts_gauge_updates/bundles/org.openhab.ui/bin/org.openhab.ui-3.1.0-SNAPSHOT.jar

Same fix also helps my (old) iPad running 10.3.3 to display content properly:



EDIT: One can always revert back to latest “official” snapshot version using

bundle:update org.openhab.ui https://ci.openhab.org/job/openHAB-WebUI/lastSuccessfulBuild/artifact/bundles/org.openhab.ui/target/org.openhab.ui-3.1.0-SNAPSHOT.jar

Please let me know how it goes!

1 Like

Just tried your patch on an iPad 3 with iOS 9.3.5:

193 │ Active │ 80 │ │ openHAB UI :: Bundles :: Main UI

Unfortunately it does not resolve the issue. Main UI does not load at all, screen (Safari) remains empty.

EDIT: Framework7 (v5) needs Safari 9.1 and iOS 9.3.5 ships with Safari 9.0 so unfortunately MainUI will not run on iOS 9.3.5 - iOS 10 is required as minimum.

Patched version works on iOS 10.3.3 - and on my LG TV (webOS 5 with Chromium 68) for that matter …

Will this be merged into OH3.1?

If others confirm it’s working for them then I’ll do a PR and lets see :wink:

Looks better on my main TV with the latest version. I see the locations now.

193 │ Active │ 80 │ │ openHAB UI :: Bundles :: Main UI

Not all things are lined up. For example the close button is a cross, with aside a circle?
See picture for more info:

I validated it on 2 television:

  • webOS 4.9.0-53405 (Chromium 68) > OK
  • webOS 3.3.5-4323 (Chromium 53) > not OK (doesn’t show anything)

I guess rendering will not be ideal on old(er) browsers - and specially Chromium 53 is quite a stretch (5 years?) …

As far as I was playing with webOS 5 (Chromium 68) it worked well (not ideal), but still useful.

Know what you mean. But it’s sometimes a pitty who fast something is ‘old’…

Do you also have the ‘outlinement’ of the icons? Or is this something with my installation/configuration?

Do you also have the ‘outlinement’ of the icons

yes, I see it too, but does not seem to affect functionality …

By “old” I mean - its strange that i.e. (pretty) new LG models bundled with webOS 5 are still shipped with Chromium 68 (from 2018 AFAIK) - so its not the problem with OH, but with LG shipping TVs with quite old browsers IMHO.

I just gave the modified Maini UI bundle a try using my iPad iOS 10.3.3. I double checked that it was installed and Active, even restarted OH3. Unfortunately I did not see any improvement in rendering. The icons on my Overview page are still missing and so is most of the text. This is the same behavior I observe with the unmodified bundled. Equally important I unable to unlock the Admin privileges, and the Locations/Equipment/Property tabs are missing at the bottom of the page as well. My Overview page is entirely custom widgets, but that is not the root of the issue. Everything works fine on an iPad Mini running iOS 14.4, or using Safari on a Mac, as would be expected. I guess I will just stick with HabPanel for now as I am not about to buy all new iPads just for this. I get the feeling that legacy users are being left behind with OH3 as I have other Hardware that require kludges to get working with OH3 as well. Technology marches on, but most of us can’t afford or are unwilling to spend money to keep up, so we make do with what we have.

Hm, just tried with ipad running 10.3.3 and works fine … I created a new bundle with latest code from webui, please try out

bundle:update org.openhab.ui https://github.com/crnjan/openhab-webui/raw/fetaure/support_webos5_buildin_browser/bundles/org.openhab.ui/bin/org.openhab.ui-3.1.0-SNAPSHOT.jar

and let me know the outcome …

@crnjan Thanks for taking time to respond. I just tried the newly linked bundle but unfortunately I had the same result as before, and I am unable to use the lock to gain admin features. The Overview page has a few items rendered but not all. The behavior I am seeing is the same as with the standard MainUI bundle. As before I restarted OH3.1M2 to insure the newly installed bundle was properly loaded and active. Normally I would say it is something to do with my custom widget coding, but my Overview page loads fine on an iPad Mini IOS 14.4 and the Admin Lock is not something I coded, so I don’t think it has anything to do with my MainUI implementation. I also tried Chrome, Kiosk Pro as well as Safari on the iPad4 and got the same result.

Not that I can see why this should make a difference, but are you serving the MainUI through myopenhab.org or off a local server on the LAN. I am not using myopenhab, but I know many do and thought I would ask as I try to understand why you are successful and I am not.

You are right, the admin/lock to gain admin features is really not working, but I haven’t used that so didn’t notice - I did setup everything using my computer and use ipad for viewing only …

The change I did (it’s merged already so one can use official snapshots) fixes i.e. rendering of cards on Locations tab, so from


Also equipment/properties tabs seems to render fine

Other parts are operational as well

only issue I found is rendering of (some) gauge’s, but its only a visual defect …

should be rendered as

So long story short, if one can live with some limitations/quirks and sometimes being a bit slow then ipads running iOS 10 can be used for at least viewing (I mean not administrating - toggling/manipulating switches and other UI controls works perfectly fine)…

On the other hand (to return back to OP), when accessing OH from my LG TV (webOS 5) beside some image displacements haven’t notice any other issues (admin login works, gauges are rendered perfectly, …) - so using latest official snapshots should enable this.

@crnjan Just one more question, please. I see that you are able to see and presumably access all of the tabs (Overview/Locations/Equipment/Properties) as rendered in your Overview, but you are not able to use the AdminLock. How is this possible? When I am not logged in as Admin l loose access to the Tabs. This is true both when accessing the MainUI from my iPad Mini iOS 14.4 or from my computer MacOS 15.7. Only if I am logged in as Admin do I gain access to the Tabs. On my iPad4 that uses iOS 10.3.3 one the primary issues is that I cannot use the AdminLock. It does NOT function as you were able to verify, therefore I cannot log in as Admin and as a result I do not have access to the Tabs. Also I believe the lack of access to Admin privileges limits what is rendered in the Overview since I need access to icons and fonts that are stored on my server for my custom widgets. How are you gaining Admin access on your iPad iOS 10.3.3 if you cannot use the AdminLock? Am I missing a setting or is another explanation? Thanks for any insights.

Hm, by default seems all users can see Locations/Equipment/Properties … at least I don’t remember changing anything …

Maybe check this?