OH3 mainui stopped displaying state values and only shows "-"

My mainui stopped showing state values in allmost all places except the settings → Items list view. Everywhere else it just shows “-”. Trendline on widgets still shown correctly though as well as graphs in the “analyse” view.

It worked until yesterday and I cant figure out what causes this change of behaviour. No error messages in openhab.log, events.log shows the items updating correctly.

Only thing i remember changing was updating the amazonechocontrol binding to the updated one from Smarthome/J - which worked fine yesterday. Reverting that change did not fix the problem though.

probably a problem with SSE as discussed here, here and here.
A ticket has been opened here

Thanks for the pointers.

I found out that my problem only exists on one of my computers independent of browser type/version.

I then found out this is due to “Sophos Endpoint Security” running on this computer:

Sophos seem to not handle SSE events on unencrypted HTTP well.

Everything works as expected thought when changing from http://host:8080 to https://host:8443

The stackoverflow answer has a workaround for the plain http case too but that is pretty ugly imho.

good finding. will try that, too. thanks