OH3 MQTT Problem

Hello, my mqtt connections stopped working after OH3 passed.
When I check with MQTT.fx, I see the values coming up.

This is what I wrote in the item;

Number NaturelGas_A_Kitchen “Naturel Gas [%.0f PPM]” (A_Kitchen) {mqtt="<[broker:kitchen/gas:state:default]" }

What kind of setting do I need to make OH3. Please help me. I’ve been dealing with this for 2 days. I can’t figure it out.

So you moved to OH3 BEFORE making the change from MQTT Version 1 to MQTT Version 2!
OH3 does not support any version 1 binding. So now you have to make the move. Start reading the docs!

I try to read the documentation, but I could not see a very detailed explanation. If I catch the trick, I’ll do the rest.

Tell us exactly which bit you don’t understand, because this is the second time we’ve mentioned to you that MQTT v1 doesn’t work in OH3!

1 Like
ok i realized that mqtt v1 is not working. But I did not understand how to upgrade the existing to V2. What is missing with mqtt in my system? I would be glad if you could help detect it.

I think what is missing is that you haven’t read the very specific link we gave you, which very specifically outlines how to convert an MQTT v1 Item into an MQTT v2 Thing and Item - that’s all you need to do.

Try converting using the information in the link provided, then if it’s not working show us your work in progress and we can help!

Let’s think like this, how to make a new mqtt V2 connection, please help me on that.
I delete the V1 ones, do it again as V2.

MQTT system broker connection settings are empty in OH3.

Please try to understand that the people answering in here might be the same that wrote the documentation. So if they are pointing you to the documentation they are exactly doing what you desire.
A search on this forum might as well give lots of hints. This problem has been met by a great amount of users since the release of MQTT version 2 ( 2years ago).

Good. You don’t need any System Broker Thing unless you use the embedded broker app (Moquette) - and that’s been removed from OH3 for support reasons.

You just want an ordinary broker Thing pointing to your pre-existing MQTT broker, Mosquitto or whatever you use.

Ok, Thank you

It looks like the documentation has a tutorial on setting up MQTT in OH3 via the MainUI:


Thank you

Hello, I have set mqtt, but now I get the incoming data undefined warning. Where am I doing wrong here? I am waiting for your help.

Please discribe in more detail how you

Without the details what you really did we can’t tell what is missing or wrong.

I guess you have setup your MQTT broker as with version1.
You should have created a MQTT Broker Thing (which should bridge from MQTT to the Things).
You should have created a generic MQTT Thing, connecting to the MQTT Broker Thing. This Thing should have at least the Number channel. How did you setup its “stateTopic” and TansformationPattern?
How did you link the item “outtemperature” to the above channel?

@haybolat in the meantime I have created a Tutorial topic on setting up MQTT within OH3. Let me know if you think this is (or would have been) useful.

1 Like

“[OH3] MQTT Setup and Configuration, post:1, topic:111494”]

Overview In order to use MQTT devices, the following is required: An MQTT broker installed MQTT Binding installed in openHAB MQTT Bridge Thing configured in openHAB This tutorial was written with openHAB3 running on a headless Raspberry Pi 3B with Raspberry Pi OS, with SSH access. Method 1. Install the MQTT broker Install Mosquitto On the Raspberry Pi, perform the following commands to install Mosquitto, and ensure it runs when re-starting the Pi: sudo apt install mosquitto sudo systemctl …

Thank you very much. I really like. But Openhab3 also have problem with mqtt broker. If I set system locale to ‘tr_TR.UTF-8’, my mqtt broker setting page is blank. this is a system error. Please let us report this, let’s get it fixed.

Best Regards…