OH3: New devices are not found in the Alexa App

Tags: #<Tag:0x00007efec7ebf768>

Hello,

after a fresh installation, two days ago I added a new (virtual) Rollershutter item for Alexa via an .item file, and it worked. The transferred items continue to work.The next day I wanted to add more similar ones now that is no longer possible. even a simple switch is not found. I’ve already tried everything possible from other older forum posts (Clear Cache, deactivate / activate Alexa app etc.)
Switch Alexa_Test "Testswitch Alexa" ["Switchable"] {alexa="PowerController.powerState"}

Kernel = Linux 5.4.79-v7+
Platform = Raspberry Pi 3 Model B Rev 1.2
openHABian 3.0.0

Have you gone through the troubleshooting guide? Make sure to stagger your changes. You most likely have one or more items with a bad Alexa configuration which are preventing the discovery process from completing.

I would like to describe the error I have again in more detail.
The Alexa app can no longer find new devices. The connection between Alexa App and myopenHAB and my local openHAB 3.0.0 works. I can control the devices that were created a long time ago with the Alexa app and also voice commands. A new item created at the beginning of the week has been found and can be used. But suddenly no more new devices were found. There are no duplicate names (IDs, labels).

Have you rolled back your changes up to when it was working before and then stagger these changes to determine the culprit item(s)? Like I said before, you probably have a bad configuration. There is unfortunately no other way to troubleshoot this.

I have a very similar or even the same problem.
In my case it is about roller blinds, which I want to connect to Alexa. I can’t find any “PowerController.mode” or “PowerController.toggleState” elements in the Alexa app. Only when I select “PowerController.powerState” the app finds the blinds.

i even used the settings from the doc. but no elements show up. If I use “PowerController.powerState” they don’t work as configured (e.g. I say minimum step size: 10 but Alexa does 1…).

These are invalid capabilities.

Please include more information such the item definition and the exact utterance you are requesting.

I thought since “ModeController.mode” and “ToggleController.toggleState” in the manual (Amazon Alexa Smart Home Skill | openHAB) these should also work. I followed the 2 examples, but unfortunately the Alexa app does not find any new devices when I use these settings.

However, if I set “RangeController.rangeValue” the Alexa app finds the blinds. But I can’t control my blinds in steps but only fully open or fully closed.
Therefore I have not set 10% steps as in the example but 100% steps.
Enclosed my Config.
With “Alexa lower the shutter xyz” the value is reduced from 100 to 99. I suppose if I say that 100 times I come to 0 and the blind would actually close :wink:
If I push the slider from 99 to 0 via the Alexa app, everything also goes down.

My blinds are connected via KNX switches and two Modbus relays at 100% the UP relay is set to high and the down relay to low. When moving down, the relays are switched inverted.

The precision of the supportedRange parameter is only used for increment or decrement utterances (e.g. Alexa, increase the blind opening). So it doesn’t come into consideration when requesting a semantic action.

For that one, based on your expectation, you need to set your lower and raise action mappings to a specific value and not a delta adjustment one actionMappings="Close=0,Open=100,Lower=0,Raise=100".