OH3 not charting any more (partly)

Running OH 3.3.0

Some days ago I´ve realized that some items are not charting any more. Even if you go to the item description try to “analyze”. Values are written well, but even no charts.

Persistance is default rrd4j, active

already checked:
\conf\persistence\rrd4j.persist
\userdata\persistence\rrd4j\

Looks good so far, but some (not for all items) charts just freezed with a value, e.g. 20C, and not updating any more.
Have also tried to delete some files from “\userdata”, and new files are created immediately, so this works.

Tried to delete cache and also tested another browser: didnt help.

Items: Point/Number. e.g. there is one Fibaro Luminance/Temperature sensor. Luminance is charting well, but not the temperature.

I can´t see any hint in the log for this issue. Chart items were not modified and are present in the sitemap. Several reboots didn´t help either. It simply stopped to chart several weeks ago

any idea?

Can’t help but second I’m seeing this on a number of OH installations and versions, too, including 3.2.0 and even before.

Please help with making developers aware of this problem. The best choice is to provide them with as much relevant data to help finding the cause of the problem. Reproduce the problem, take logs meanwhile and upload them. But reduce logging to only relevant settings. Noone is capable or willing to browse through too much noise.

Open a Github issue and provide a log what’s output when you click on ‘Analyze’.
Enable debug level debugging (or even trace lvl) on org.openhab.persistence.rrd4j and ask in the issue for other specific bundle names to also enable debug logging on that might be of relevance in this context (I’m unsure what’s involved when you click on ‘Analyze’).
Also request some enhanced logging to be built into future OH versions so we (users) in the future can get to see at least something that could help all of us in analyzing.
Key observation I believe is that to remove the .rrd file of a broken item does not help.
Try removing AFTER stopping OH but I’m also seeing instances where this does not help either.

Also try 1) changing default persistence to some other database (influx, mariadb, jdbc, whatever) and try 2) to establish another db persistence in parallel with default rrd4j and compare items across those two persistence .

FWIW, I have an item I cannot chart but as a trendItem in MainUI, the curve is being shown.
@alex_alexandroff22 have you considered opening an issue ?