OH3 Onewire temp sensor config error

  • Platform information:
    • Hardware: Virtual machine on proxmox, 4xKVM processor (i3-8100) 8GB virtual RAM (32GB)
    • OS: Ubuntu 20.04LTS
    • Java Runtime Environment: Zulu 11
    • openHAB version: 3.0
  • Issue of the topic:

I’m configuring my onewire devices, and have a problem with the sensor.
Got a esera OW ethernet controller. Which has a binding with OH as you can see below

Then i’ve tried to add a sensor, but unfortunately i got an error as you can see below

I think it has something to do with the sensor ID. In other topics i’ve seen that everyone has an ID with 12 symbols. The id of the sensor im using has 14 symbols. But i can’t change it in the controller software to 12.

As you can see below, the sensor is working fine. 14,93 degrees.

Just try with only 12 characters (leave out last two) on openHAB.

Why don‘t you use discovery?

Have tried with only 12 characters.

Did a scan in the OW binding, but without any result.

If discovery does not find the sensor, it is not reported correctly from the server. You could check if the log reports something. Probably increasing the loglevel to DEBUG for org.openhab.binding.onewire could give some more insight.

Had a look in the log-file.

2021-01-06 09:07:30.904 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler OwserverBridgeHandler tried updating the thing status although the handler was already disposed.

Will increase the loglevel to DEBUG tomorrow to see if there is more info

interesting i see you use a esera config tool. i use the esera buskoppler usb pro but i didn´t know about the existence of such a tool.

did you use it on oh2.5 already or newly on oh3? i onyl use the ow-server with a couple of ds18b20 sensors on a rpi4b and running oh2.5 with a textual config.

the only difference i can see is that i use the local network address because esera is connected direct to the raspi.

this are my things and items, perhaps it may give you a hint:

// **********************************************************************************************************************************
// 1wire Temperatursensoren, angeschlossen über ESERA Buskoppler
// **********************************************************************************************************************************

Bridge onewire:owserver:mybridge [
    Thing basic OwTemp_KWL_Aussen "OwTemp_KWL_Aussen" @ "Temperatur" [
        Type temperature:temperature

... more sensors and ist channels ...


Group iG_OneWire "Alle 1Wire-Temperatursensoren" <temperature>      // verwendet für influx-persistence

Number:Temperature iOwTemp_KWL_Aussen           "Außen [%.1f %unit%]"                   <temperature> (iG_OneWire) { channel="onewire:basic:mybridge:OwTemp_KWL_Aussen:temperature" }

... more items ...

additional infos that i realized and noted sometimes:

  • the 1wire web-directory does not work, doesn´t matter, not needed
  • the path /sys/bus/w1 does not exist
  • the path /mnt/1wire is empty, not needed

and one last thing: i had to edit the /etc/owfs.conf:

! server: server = localhost:4304
#server: FAKE = DS18S20,DS2405
# ESERA 1-Wire-Buskoppler
server: device = /dev/ttyUSB0
(alles dazwischen kann mit "#" ausgeklammert werden!!)
http: port = 2121
ftp: port = 2120
.. dieses mal aktiv gelassen
server: port = localhost:4304

Have set the log level to DEBUG, but can find anything with DEBUG in the log files.

However the log file was full with the message below.

at org.openhab.binding.onewire.internal.owserver.OwserverConnection.readDecimalType(OwserverConnection.java:195) ~[?:?]
at org.openhab.binding.onewire.internal.owserver.OwserverConnection.checkConnection(OwserverConnection.java:410) ~[?:?]
at org.openhab.binding.onewire.internal.owserver.OwserverConnection.read(OwserverConnection.java:494) ~[?:?]
at org.openhab.binding.onewire.internal.owserver.OwserverConnection.request(OwserverConnection.java:305) ~[?:?]


Yes it’s quite a usefull tool, but i dont think it wil work with an USB controller, only with ethernet/modbus.

I haven’t used it with OH2.5. Setting up everything now for the first time in OH3

I’ve checked the code in OH3, and compared them with your code, but can’t find anything strange.


Have been reading a lot, and i think i must add an OWFS channel in the bridge binding?
Have searched for something like OWFS in the esera CONFIG tool 3/controller, but didn’t find anything.
Maybe if i install OWFS on the openhab server(Ubuntu20.4) it would work?

Hi @Tiender,
did you manage to connect your Esera Onewire Controller with OH3?
With OH2.5 I was happily using the TCP/UDP binding (see here [SOLVED] How to read values from Esera 1-Wire Controller - #2 by Digitalvitamin). But the binding is not available for OH3 anymore - so I am looking for alternatives.