[OH3] Semantic modelling in UI not possible

  • Platform information:
    Raspbian GNU/Linux 10 (buster)
    Kernel -> Linux 5.4.79-v7l+
    Raspberry Pi 4 Model B Rev 1.4
    OpenJDK Runtime Environment Zulu11.43+100-CA (build

Trying to follow Yannicks presentation during the Virtual Meetup. I choose Model in the left column, click Add Location, enter values (tried Yannicks values: gGF…) and the click either on the line saying Type or Semantic Class, a popup opens and now:

regardless what I choos / click in the popup I will be thrown back to the Setting start page and no entry in Semantic Model is saved.

Am I doing something wrong? From other threads I get the impressing that this UI modelling should be working.

Kind regards.

What did you enter for the other values?

I just tried it (I built my location model a month or so ago) and it worked as expected.

I copied Yannicks entries exactly; Name gGF, Label Ground Floor, click Category, type grou… select groundFloor (icon changes), click Semantic Class, choose GroundFloor - and boom: I am back at top level Settings in the left Navigation column.

What browser are you using for configuration? I ocassionally experience such throwbacks with Safari.


I’m using Edge (Chromium) on Windows 10.

LOL - followed the bowser hint: using Chrome on macOS everything works.
EDIT: Chrome on Windows 10 is also working.

For Edge is the Windows default browser, I hope this bug will be resolved.

1 Like

I suspect a lot of data will need to be gathered and an issue filed before that’s likely to occur.

I think that will be more a problem of how Microsoft is implmenting Chromium into Edge.

I have the same issue sometimes with Firefox. What helps to “solve” it is deleting the session of MainUI, logoff and login again.

1 Like

Maybe the developers will give us a word how to handle this in accordance to their own priorities and plans. For the time being as a workaround: Goggle Chrome seems OK on Windows 10 and macOS.

Do you experience the same behavior with Firefox on your System?

For this problem:

Windows 10
Edge (Chromium): fail
Chrome: OK
Firefox: OK

Safari: OK
Chrome: OK
Firefox: OK

1 Like

Most of the devs are on holiday break. So this doesn’t get forgotten, I still recommend filing an issue at the openhab-webuis repo. The template of the issue will tell you how to gather a bunch of information that they will need to diagnose and fix something like this including logs from the browser’s developers console.

This is happening erratically and it’s quite irritating. I’ve never been able to pinpoint the exact problem but it seems the framework7 router gets confused does a “double back” when and you click back once, not even sure if it’s a bug we have to escalate or not. It’s usually solved with a page refresh.

Yes, I can confirm the erratic behavior. During the last days, sometimes I could model in Edge, too. Then again not.

An annoying “me too” on the ‘double-backing’ issue. I use Firefox on Ubuntu 18.04, with OH3 installed from the apt repos.

A page refresh gets everything back to normal, until the next random time…