OH3 UI and Android App myopenhab problem

Hello I am having a connection problem in “WAN” mode with the Android app, I use the “token” as login and in “LAN” it works very well, if I switch to “WAN” on the other hand I have a error message “http 401” httpClient $ HttpExeption / UNAUTHORIZED, I nevertheless have access to my “myopenhab” and see my UI in http but not through the Android App, I also tried the “login mode” “+” pwd "but that doesn’t change anything. Where does my problem come from?

ps: I have correctly installed the binding with used “UUID” and “Secret” and I can connect online via Chrome or other, thank you in advance, because I am lost

IMHO the token does not work when trying to connect via myopenhab.org, You do need the username and password known by openHAB!

thanks , i try also and still the same

Working at my end. Under what circumstances ard you able to use the app when outside your local network? ( only if no token is used, neve or etc…)

I use it outside my home to view, operate, check exc … every day, portal, exc messages …

So it was working for you and it isn’t working if you are using the token for the local net, correct?

in fact with OH2 I have no problem, now I created a new myopenhab account to use OH3
, to connect via the android app I use the token and locally it’s going very well, in “wan” impossible, even if I remove the token and that I use my login and password “myopenhab”

So the newly created myopenhab account never worked?

it work actually but only via Chrome or firefox , it never worked whith OH3 through App Android no

…and you checked the correct spelling of ( new) username and password, I guess. Running out of ideas! :thinking:

same here…strange…i know , thanks for your help

I tried to get the remote connection with the token again ( unsuccessful!), when setting it back I had to completely close the app in order to get a connection.

I I just tried, but without success, thanks again for your help! :slight_smile:

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.