OH3: „Umlaute“ change to „?“ after restart


at OH3 i got a problem with „Umlaute“ (ä, ö, ü):
After a restart they always change to „?“.
It seems to effect every Type of Label (Item, Things, rules, …)

Is this a known Problem and is there a Solution for it?

Thanks, Alex


I have several things and items in OH3 that have a label containing Umlaute. Can you give some more information regarding your setup (e.g. operating system)?

My OH3 is a fresh install on a Debian9 (Proxmox LXC on HP ProLiant DL360p)).
I can edit and save the Labels with Umlaute, but after a restart of the Service they change.

I am also using Proxmox, but I have chosen to install openHAB in a VM running Ubuntu 20.04. What is the locale used in LXC? What language and country did you set in the openHAB administration panel?

I am not sure if that matters but how do you edit your things, items, rules ( in the UI, in the file system on the debian system or via mapped drive under windows ) ?

Noticed the same problem with my installation.
Running on Ubuntu 20.04.1 in a lxc-container on proxmox.
My locale was on the default ‘C’ value, changed it to en_US.UTF-8 and the problem does no longer occur.

Thanks for your replies so far, here are my region settings at OH3:

How to i set the locale at proxmox? I just found the settings for the timezone in the UI:

I think you need to set the locale in your LXC container. You can find instructions on how to do this on a Debian system here. Choosing any UTF 8 locale should work. You probably want to set de_DE.UTF-8 as your default locale.


Thanks, this seems to work!

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.