OH3 with Conbee II for Zigbee in a Proxmox LXC

OH3 with Conbee II for Zigbee in a Proxmox LXC:

  • Platform information:
    • Hardware: Intel NUC i5 BDH
    • OS: Proxmox v 6.3.3 with OH3 running in LXC
    • Java Runtime Environment: openjdk version “” 2020-11-04
    • openHAB version: Latest version 3 installed with openhabian (9-2-2021)
  • Issue of the topic: please be detailed explaining your issue
  • Please post configurations (if applicable):

I started from scratch with openHAB v 3 on a new Intel NUC. I run Proxmox v 6 as host OS and created a LXC container with Debian 10 for openHAB3.
Installed openHAB3 via openhabian and it seems to run fine. I am able to configure openHAB3.

But the first step was to get my Z-Wave and Zigbee dongles working. (I used the same dongles which i had on my OH 2.5 on RPi2). I have the Aeotec Z-Stick Gen5 and the Conbee II sticks connected to an USB hub and put the USB-hub in the NUC. (Same USB Hub was used on RPi).

I managed to get both USB interfaces as USB Passthrough from the Proxmox Host to the LXC.
It required some searching to get this working, but i managed.
My Z-Wave dongle is working as it should. But the Conbee II dongle with deCONZ, I am not able to get it right.

In OH3 i installed the deconz-binding. Next i wanted to configure the Thing for deCONZ. But this needs the API KEY in order to work. But i could not find a way to get this API Key in the Proxmox LXC.

So i tried the following. I took the Conbee II dongle and put it in my Win-10 machine and via a REST API plugin in the browser i was able to follow the instructions from the
Dresden-elektronik website
Now i was able to get an API Key. So i moved the Conbee II dongle back to the Intel NUC and configured the deCONZ Thing with this API Key.
If i look at the deCONZ Thing, this is the Code:

UID: deconz:deconz:210c4b61f7
label: deCONZ
thingTypeUID: deconz:deconz
  host: /dev/ttyACM1
  apikey: 08780DCE0B6
  httpPort: 80
  timeout: 2000

But the Thing remains in: image

I am not sure if this method for aquiring the API Key is valid. But i do not know how to get the API Key in the LXC where OH3 is also running.
Btw, my Z-Wave dongle on /dev/ttyACM0 is working perfectly, So it has nothing to do with the USB Passthrough configuration.

Hopefully someone can shed a light on this…

OK, creating an API Key for the deCONZ/Conbee II for use in the openhab add-on does not work if you do this on a Win-10 machine. Apparently, this must be done with the Phoscon Software on the same machine as where the Conbee II stick will be used.
So i installed this software (Ubuntu version) in the LXC where openhabian is running. Then i got the next issue; the OS used (Proxmox Temmplate Debian 10) for this LXC does not have a GUI (server version), so using the Phoscon software is a challenge.
First i tried to install a GUI, but runned in several issues by the install.
I found a way to bring the X server to a windows machine using X2Go Server and on Win-10 X2Go Client.

sudo apt install -y xfce4 x2goserver x2goserver-xsession

But running the Phoscon search app did not find the Conbee II Gateway.


Unless somebody has a suggestion, i think my next step, i go and try a VM on Proxmox for the setup of openhabian with my Z-Wave and Zigbee USB devices.
(My first choice for a LXC was inspired by the lesser resources needed vs a VM).
Well for me as a Proxmox novice, it’s an inspiring experience working with VM’s and LXC, i learn a lot from it :wink:
I will post an update when i got it working in a VM…

Hello, would you be able to elaborate on how you got the Serial Port for your Zwave Stick Gen5? I have the USB passthrough configured and see the stick in my LXC container with “lsusb.” Thanks

Hi Matthew,
Later in 2021, I switches from openHAB to Home Assistant. Reason was the continuers problems i faces with programming Automations in OH. (I am not a programmer)
So i really don’t remember how i had the pass through for my Z-Wave stick had configured
Kind regards, Bert