[OH3] Z-Wave - Is it possible to force-reinitialise devices without re-pairing?

The example below is about Spirit thermostats I am playing with now, but the question might be more universal.

If I install the Eurotronic Spirit with the Aeotec Z-Stick, after a short while they show up as Eurotronic Spirit Thermostats. So far so good.

But if I then move the Z-Stick to a different PC running fresh install of openHAB, the Z-Wave nodes are recognised, but they remain an unknown device. I’ve tried to wake them up by changing the temperature / put them in in learning mode (press the middle button for a while) and tried soft-reset, heal and reinitialise on the Z-Stick and the unknown Z-wave nodes as things (where possible).
Nothing helps. They remain unknown.

Is there a way to force re-initialisation of the devices?
I also tried to copy the .xml files from the userdata/zwave dir of the other PC, but also after a restart it did not make a difference.

Is there way to force-reinitialise the devices, so they are not Unknown anymore and the channels become available without re-pairing them to the Z-stick?

I am assuming both systems are running a recent version of openHAB. Other systems, such ad Home Assistant must see the device as it is included into the network.

Try either restarting the zwave binding or restarting openHAB and then waking up the devices until discovery is complete.

1 Like

Yes one is on 3.0.0 M1 another on 3.0.0.-SNAPSHOT from 2 days ago.
So only waiting and trying to wake them up? I already tried this, kept openHAB running for hours, restarted openHAB, restarted the binding, anything I can think of. The only way to wake the nodes up is by changing the temperature I guess or is there a magic trick I don’t know about yet? Tried it all (I think), but nothing seems to happen…

When installing them ‘clean’ on openhab they are recognised right away as Spirits.
So here it also seems as if openHAB needs to see the devices as they are included into the network.

For production use, this is no problem. But I’d like to use the same z-wave network on 2 setups, so I can switch from production to develop, by swapping the z-wave stick.
Maybe this is done better by sharing a backup (there is more to it than the usedata/zwave/*.xml files it seems).

I believe Z-Wave was broken on 3.0.0 M1.

ok I know M1 did not want to see the devices already on the network of the stick (coming from Home Assistant) but the SNAPSHOT also does not see them now (after a full reset of the stick and re-pairing them with M1).

The joy of cutting edge… I’ve upgraded (with sudo apt-get upgrade) and now I get errors on openHAB snapshot… So first I’ll need to figure out what goes wrong…

I don’t really know what this means, but I suspect it is not going to wake up the device. Normally there will be a button, or sequence of presses to wake up the device. Just causing it to send data is not normally the same as waking up the device.

Yes, there is a “reinitialise” option in the device configuration.

You need to wake up the device - reinitialising the device through the binding will make no difference if the device does’t wake up, and tha can only be done from the device.

Ok thank Chris. I will re-read the manual to see if there is anything about wake-up (can’t remember it)
If anyone else knows, please enlighten me…

Actually, this device is a FLIRS device so it doesn’t need to be woken up - it’s basically always awake…

1 Like

I just read the manual and indeed nothing about wake-up :wink: .
But it also is not recognised when you put a Z-stick in a different install of openHAB…
So how can FLIRs devices be recognised again? If possible at all of course.

A FLIRS device doesn’t sleep - it is basically awake all the time (but a little slow to respond) and therefore acts like a mains device.

Yes I get that :slight_smile: But how can openHAB be enticed to query it again ?

1 Like

It should query it normally - but I don’t know what you mean by “again”? What is happening that is stopping it from communicating? I think you need to answer that first? Is there a communication problem, or something else?

Restart the binding?

The nodes are found. All seems ok. But it stays as “Unknown Device”… it never becomes a Eurotronic Spirit.

Moving the stick to a different OH instance

Guys, random guessing won’t really help. Please let’s take a step back and try and see what is actually happening. Why isn’t it communicating? What do the debug logs show?

We can play 20 questions and guess what might help, but the logs are likely to provide at least some indication of where to look when something isn’t working.

1 Like

What happened:

  1. I put a stick with a network of 2 devices created in Home Assistant in an openHAB 3.0.0-M1 instance. The network and nodes were recognised, but the Thing Type stayed ‘Unknown Device’.

  2. I did a hard reset of the Z-Stick. I included 2 Eurotronic Spirits on that openHAB instance. They were immediately recognised as Spirits :slight_smile:

  3. I moved the Z-Wave stick to a different instance of openHAB (3.0.0-SNAPSHOT).
    Again the network and nodes are recognised, but the thing type stays at ‘Unknown Device’

The log shows:

2020-11-02 21:09:30.878 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2020-11-02 21:09:30.879 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.
2020-11-02 21:09:34.362 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 3: Device discovery could not resolve to a thingType! 0148:0003:0001::0.16
2020-11-02 21:09:34.365 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 2: Device discovery could not resolve to a thingType! 0148:0003:0001::0.16
2020-11-02 21:09:38.658 [WARN ] [.ZWaveThermostatSetpointCommandClass] - Reached max tries to init the setpont Furnace, this will be our last attempt 

This indicates that the database entry is missing. Please use the OH3_M2 binding.

I will try it. Will be a manual install, the packages via the package manager are not working for me.

This means that it was not working (yet) on the M1 release, because I had the same problem with it.