OH3 zwave changed to offline after clicking "Exclude devices"

I’m using OH3 (on Docker) for a while. and today I wanted to remove one device from the network, I entered the ZWave binding thing in the UI and clicked “Exclude devices”.
since then all the devices changed to OFFLINE and the aeotec USB stick changed to OFFLINE.
I tried to remove it and add the thing again. nothing helped.
try to install again in karaf feature:install openhab-transport-serial and restart to zwave binding - but still the same thing…
permissions to stick are okay, container running in high priority, controller react to cat /dev/ttyACM0, but still nothing in OH3 UI.

Any suggestions?


2021-04-19 22:54:25.537 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zwave:serial_zstick:Zwave' changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to UNINITIALIZED

2021-04-19 22:54:25.546 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - ZWave discovery: Deactivate zwave:serial_zstick:Zwave

2021-04-19 22:54:25.549 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zwave:serial_zstick:Zwave' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)

2021-04-19 22:56:04.405 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - Creating ZWave discovery service for zwave:serial_zstick:Zwave with scan time of 60

2021-04-19 22:56:04.407 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - ZWave discovery: Active zwave:serial_zstick:Zwave

2021-04-19 22:56:04.544 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zwave:serial_zstick:Zwave' changed from UNINITIALIZED to INITIALIZING

2021-04-19 22:56:04.560 [DEBUG] [zwave.handler.ZWaveControllerHandler] - Initializing ZWave Controller zwave:serial_zstick:Zwave.

2021-04-19 22:56:04.565 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'zwave:serial_zstick:Zwave' changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline```

A handler missing error usually indicates the binding was uninstalled?

I won’t be able to help too far on Zwave issues but I do know that if the controller is offline all the devices Things connected to that controller will also be offline. So focus on the controller.

Have you restarted the machine? If there is a lock on the serial device file OH won’t be able to access the device. If you’ve unplugged the controller and then plugged it in without stopping OH, it will attach the controller to a different file (e.g. if it was at /dev/ttyACM0 it will return on /dev/ttyACM1). Restarting the whole machine, not just openHAB can clear any of that sort of thing up ensuring you are running with a clean slate.

Make sure the serial transport bundle and zwave bundle are indeed installed and active.

Those at least are the first steps I would take.


I reinstalled the docker (with the same configuration and userdata files) and now it is working…
(this mean it is problem with the openhab state)

1 Like