[OH4.1] [androiddebugbridge] Thing ip address changes to link-local ipv6 automatically


I have 3 T-Home android box in house which can be controlled with Android debug bridge. Since OH 4 the IP address of each bridge changes from pre-entered fixed IPv4 address to a link local IPv6 address - probably autodiscovery kicks in somehow. I’ve reentered IPv4 address manually several times and I configured the binding settings all to zero to turn off discovery but has no effect. How to keep a thing IP Address and restrict the binding to change to something else? Is this a bug?

I’ve found a lot of these in openhab.log

2024-01-09 18:24:03.948 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception:
java.lang.IllegalStateException: connect() must be called first
at com.tananaev.adblib.AdbConnection.open(AdbConnection.java:321) ~[?:?]
at org.openhab.binding.androiddebugbridge.internal.AndroidDebugBridgeDevice.lambda$5(AndroidDebugBridgeDevice.java:759) ~[?:?]
at java.util.concurrent.FutureTask.run(FutureTask.java:264) ~[?:?]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304) ~[?:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1136) [?:?]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635) [?:?]
at java.lang.Thread.run(Thread.java:840) [?:?]

Thank you.

I suggest disabling IPv6 on your openHAB server, which will force it to communicate via IPv4.

IPv6 is becoming necessary as the Internet grows, but (in my opinion) doesn’t offer much benefit on a home network at this point in time, since we don’t need that many IP addresses locally. And as you’re finding, it hinders communication that’s designed to route via IPv4.

You may be able to disable IPv6 at your router, but be careful only to do so for your internal LAN.

@Steve_Hooser: That was really helpful. :blush:
@rpwong: Disabling IPv6 is not an option. I think this should be solved on the level of the binding itself. Probably I’ll report a bug on github…

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.