OH4 sign in fails repeteadly on snapshot

using latest snaphosts for openhab-addons and openhab-distro in Eclipse IDE.
When I try to login to localhost:8080 login fails like in animation below.

GIF 11-06-2023 19-06-47

On logs I read:
16:57:51.504 INFO [OH-ruleengine-1 ] [mation.internal.RuleEngineImpl:1446 ] - Rule engine started. 19:05:29.851 WARN [qtp1918770618-224 ] [st.auth.internal.TokenResource:325 ] - PKCE verification failed 19:05:29.854 WARN [qtp1918770618-224 ] [st.auth.internal.TokenResource:135 ] - Token issuing failed: invalid_grant

I already tried to delete files in runtime/userdata/jsondb and re-created admin user, but nothing changed.
Any idea?

Same for me with today snapshot and error in log during start:

2023-06-11 10:37:19.414 [WARN ] [rd.internal.AriesJaxrsServiceRuntime] - Extension CachingServiceReference {
cachedProperties={service.id=289, objectClass=[org.openhab.core.io.rest.auth.AuthFilter], osgi.jaxrs.name=null (cached), osgi.jaxrs.whiteboard.target=null (cached)}
serviceReference={org.openhab.core.io.rest.auth.AuthFilter}={service.id=289, service.bundleid=176, service.scope=bundle, osgi.jaxrs.application.select=(osgi.jaxrs.name=openhab), osgi.ds.satisfying.condition.target=(osgi.condition.id=true), component.name=org.openhab.core.io.rest.auth.AuthFilter, service.config.label=API Security, component.id=153, service.config.factory=false, osgi.jaxrs.extension=true, service.config.category=system, service.config.description.uri=system:restauth, service.pid=org.openhab.restauth}
} is not valid

It seems this could be related to:

Have you also tried cleaning the cache?

Cleaning cache nothing help.

I did fetch --all, rebase -i, clean install -U on openhab-distro, but problem is still there

Build 3493 fixed the issue on my side.

1 Like

Same here: with a new update the problem disappeared.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.